Cannot do an expo local ios development build, cocoapod error

I am getting the error below when attempting to create an ios development build of a simple test app; android builds work fine.

This occurs building on my 2014 Mac, stuck at BigSur 11.7.10 and Xcode 13.2.1. However, I can build ios and android development build successfully on my 2021 Intel Mac running Ventura.

I have tried all the obvious solutions. I uninstalled and reinstalled Xcode and cocoapods. I have updated BigSur to the latest available. I did prebuilds, deleted the ios directory and tried a manual pod install.

------ this is what happens --------

npx expo run:ios

:warning: Something went wrong running pod install in the ios directory.

Command pod install failed.

└─ Cause: Couldn’t determine repo type for URL: [](`): SSL_connect returned=1 errno=0 peeraddr= state=error: certificate verify failed (unable to get local issuer certificate)

I have searched for this error with no success. To me it looks more like a problem with HTTPs certificates than expo.

Any help would be greatly appreciated.

pod install --repo-update --ansi exited with non-zero code: 1