Build iOS .ipa [stderr]


I have a problem building and signing IPA.
I don’t know how resolve it.

Hey @giuliabreviario,

Can you run expo diagnostics and paste the log that’s printed out here?


this is the log that’s printed out:

Expo CLI 2.18.7 environment info:
OS: macOS 10.14.5
Shell: 3.2.57 - /bin/bash
Node: 10.15.3 - /usr/local/bin/node
npm: 6.4.1 - /usr/local/bin/npm
Xcode: 10.2.1/10E1001 - /usr/bin/xcodebuild
expo: ^32.0.0 => 32.0.6
react: 16.5.0 => 16.5.0
react-native: => 0.57.1
react-navigation: ^3.0.9 => 3.11.0
expo-cli: 2.18.7



Hey @giuliabreviario,

Thanks for that. Can you try clearing your credentials via expo build:ios -c and then generating new ones by running a subsequent build command? Remember you can pass the --no-publish flag to the build command if you don’t want to push out an OTA update while building.


thank you for the hint but it doesn’t resolve my problem.
I tried expo build:ios -c and I chose:

Expo handles all credentials, you can still provide overrides

The error remain the same. I can download .ipa but it failed during the installation.

Screenshot you provided doesn’t contain any errors. Can you clarify what do you mean by “during the installation”, is it when you are uploading to testfligth or when installing your app through testlight on device?


I mean that the app crashes when I installing it through testlight on device…
This is the specific error:

The translation of the error is:

the package path is missing from the request.

I wish to test the .ipa on device before publishing on the store.
I think that the problems are the red lines [stderr], but I haven’t found any documentation about it.

Debugging works properly on my mac’s visual studio code, I build the app for android and my .apk works perfectly. The problem started when I tried to build for iOS. My Apple developer account is OK and the payment method is valid.

Please I need help, I need to understand what those error lines mean and solve.
Thanks for all,


stderr messages are showing up in every build, crash in your case is totally unrelated. Can you check logs from your device when app is crashing in tesflight? I’m not really sure how reliable this translation of error message is, can you switch system to english and retry it?

I’ve switched system language to english.
this is the log:

Inside log crash of the device there aren’t any error about this app and the days I tried to install it.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.