Beginner's problem - "facebook::react::Recoverable..."

Hello. I’m new to Expo. Here’s the problem I am currently facing when I want to open the application as in the documentation, (

This is what I did:-

  1. Open Oracle VM VirtualBox
  2. Open Genymotion
  3. Start a virtual device
  4. Open Expo
  5. Create New Project
  6. Choose Tab Navigation Template
  7. It says “Project opened!..” When I choose “Open on Android”, I got errors as in the image.

Thank you in advance :slight_smile:

I am also trying to fix this problem. Anyone help? This is ok in mac…

Hello. I fixed this problem when I realized that I have problem with “Starting packager…”

When I tried to run npm start on a newly created crna app, the terminal showed “Starting packager…” for a very long time. Then, I decided to stop it and run
sudo sysctl -w fs.inotify.max_user_watches=10000

After that I ran npm start again and it worked.

I don’t know if this is the right way of fixing the problem, but it certainly did for my case.

I’m using linux mint 18.1,

1 Like

worked for me, thanks a lot!

i think it’s the problem with watchman, try this commandes :

echo 256 | sudo tee -a /proc/sys/fs/inotify/max_user_instances
echo 32768 | sudo tee -a /proc/sys/fs/inotify/max_queued_events
echo 65536 | sudo tee -a /proc/sys/fs/inotify/max_user_watches
watchman shutdown-server
watchman watch-del-all

and restart project