Assets and Vector Icons not displayed anymore after exp publish

I am facing a very frustrating issue:
After running exp publish all Assets and the Vector Icons from @expo/vector-icons are not displayed anymore. This happens for both JS urls, development and production.

It is a detached expo app and I try to run it on Android.
I tried to re-build the Android project again several times, every time it stops working after I run exp publish.

I also tried this solution of @llamaluvr but import { Asset } from 'expo'; Asset; did not help and expo-pre29.gradle does not find "./android/detach-scripts/".

I have noticed that when I run exp publish there are no changes detected, even if I delete the published project beforehand.

[17:37:04] Uploading assets
[17:37:04] No assets changed, skipped.
[17:37:04] Processing asset bundle patterns:
[17:37:04] - /home/dfels/projects/my_app/**/*

Is there a solution for this?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.