App Loads Blank Screen in iOS Build

When I run expo build:web I am able to generate my app just fine. However, when I switch to importing from react-router.native in my App.jsx file, and run expo build:ios my app consistently loads with a blank screen in the simulator and on the client app on my iPhone.

I noticed that watchman had crashed during the first few builds, so I tried to update my expo-cli and as as running brew install watchman, but it still does not work from the tar.gz file. On top of that, I now have this error when I try to use the app through Expo on my iOS simulator:

I’ve converted my import back to react-router in my code and the web build still works as usual, so I know that the caches aren’t corrupt. I think I must have missed an install/build/something-step along the way, but I’m not sure what.

Here are my dependencies:

"@material-ui/core": "^4.10.1",
"@material-ui/icons": "^4.9.1",
"@material-ui/styles": "^4.10.0",
"expo": "^37.0.12",
"expo-cli": "^3.21.13",
"global": "^4.4.0",
"i18next": "^19.4.5",
"i18next-browser-languagedetector": "^4.2.0",
"i18next-xhr-backend": "^3.2.2",
"react": "16.9.0",
"react-dom": "16.9.0",
"react-i18next": "^11.5.0",
"react-native": "^0.62.2",
"react-native-material-ui": "^1.30.1",
"react-native-svg": "^12.1.0",
"react-native-vector-icons": "^6.6.0",
"react-native-web": "0.11.7",
"react-router-dom": "^5.2.0",
"react-router-native": "^5.2.0",
"rn-draw": "^0.0.6"

@adamjnav @charliecruzan and/or anyone else from the mods team, can I get help with this? I cannot find a similar problem here or on GitHub and am lost as to what to do.