APK build not working. No errors


I’m following the steps described in the “creating your first build guide”(Creating your first build - Expo Documentation) and I’m using Expo SDK 46.0.0 (expo-managed project), EAS CLI version 2.4.1

I’m in step 4, trying to build an apk for Android for testing my app on a real device by installing it.
I already followed the configuration and the command “eas build -p android --profile preview” described here: Building APKs for Android emulators and devices - Expo Documentation, and I already made all of the changes to the eas.json and app.json files required in these guides.

I already tried my app in development in an android studio emulator as well as my real device with the expo go app and it works fine. My build is done without any issues.

I see the build in my project dashboard on the expo webpage, but the problem is, when I install the APK (either in the emulator from the android studio or my real device), the app gets installed, but when I try to open it, I see the splash screen for a second and then the app shuts down (no feedback is given).

Has someone experienced this problem before? or any good ideas on how to approach this issue?

Thanks in advance.

hi there! here’s what you can try: Debugging - Expo Documentation

this doc in general is a good reference when you’re having issues with builds: Troubleshooting build errors and crashes - Expo Documentation

I have faced the same issue, have u got any solutions

The same thing, here. Did you found solution plz?

Did you try the Debugging guide and the Troubleshooting errors and crashes? What did you try and what was the result?

I Have not found a solution, but in my case, I confirmed that it has to do with the google maps api, because i rebuilt the same app and when building and testing, I got the same error, when I built the apk and use google maps.

I did but the only thing that i manged to find was that the google maps api does not work properly for some reason when i build the release apk

Did you find anything in the device logs or when you ran the dev build or Expo Go in minified and “no-dev” mode?

I have not also find any solutions, I have changed the release channel and tried its worked fine in the new release channel, if any one find the solution let me know it will be helpfull

I have had this problem too, any solutions?

If anybody has the same problem, please explain what you tried from the links in Brent’s comment:

and explain what happened or what went wrong.

Just saying “me too” does not allow anyone to help you to solve the problem.

Experiencing same issue , Error is below :

com.facebook.react.common.JavascriptException: Invariant Violation: requireNativeComponent: “RNGestureHandlerRootView” was not found in the UIManager.

This error is located at:
in RNGestureHandlerRootView
in Unknown
in v
in Unknown
in o
in Unknown
in Unknown
in Unknown
in Unknown
in Unknown
in Unknown
in Unknown
in RCTView
in Unknown
in RCTView
in Unknown
in b, stack:
@ 20:289
@ 162:1681
@ 132:919
ua@ 34:65870
Ci@ 34:86515
Ri@ 34:86397
_i@ 34:86264
Ei@ 34:86029
yi@ 34:82985
yi@ 1
xt@ 34:27509
ci@ 34:79668
Zi@ 34:94613
@ 34:100839
@ 347:1279
run@ 338:1403
runApplication@ 338:2420
value @ 63:3821
value @ 63:2583
value @ 63:731
value@ -1

at com.facebook.react.modules.core.ExceptionsManagerModule.reportException(ExceptionsManagerModule.java:72)
at java.lang.reflect.Method.invoke(Native Method)
at com.facebook.react.bridge.JavaMethodWrapper.invoke(JavaMethodWrapper.java:372)
at com.facebook.react.bridge.JavaModuleWrapper.invoke(JavaModuleWrapper.java:188)
at com.facebook.jni.NativeRunnable.run(Native Method)
at android.os.Handler.handleCallback(Handler.java:942)
at android.os.Handler.dispatchMessage(Handler.java:99)
at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(MessageQueueThreadHandler.java:27)
at android.os.Looper.loopOnce(Looper.java:211)
at android.os.Looper.loop(Looper.java:300)
at com.facebook.react.bridge.queue.MessageQueueThreadImpl$4.run(MessageQueueThreadImpl.java:228)
at java.lang.Thread.run(Thread.java:1012)

And what were the results of what you tried?

I got this error from my Xiaomi phone, it provides error log if any app crashes. Above links did not help me. I managed to solve the issue by installing “react-native-gesture-handler” package in the project. I am not sure if it would work for everyone.

1 Like

Hello, I found this solution and worked for me.

after the build, I run the app on emulator in android studio then go to view>tool windows>logcat and check for invariant violation (on my case I needed to install react-native-screens and react-native-safe-area-context). After building new apk the app works fine.

1 Like

Good morning everyone, after racking my brain for about 2 days, what worked for me was to install “react-native-safe-area-context”, **“react-native-gesture-handler” ** and “native reaction screens”. Configure these dependencies in your App.js.

After that I gave permission in my API key to Geocoding Api, Maps JavaScript API and Maps SDK for Android.

In app.json add your API key, like this:

    "android": {
       "config": {
        "googleMaps": {
          "apiKey": "api_key"

I generated the build, installed it on my phone and it worked. If yours doesn’t work, use Android Studio’s logcat, which shows all your app’s errors.

Hope it helps someone!

1 Like