Webview-based Library Stopped Working on Expo iOS App, but works on app built 2 months ago

One of my app that was built for iOS using Expo SDK 34 and published on the app store 2 months ago uses a Webview based library for drawing charts. This app on the App Store is still rendering the charts properly.

However, right now when I used expo start to run the exact same code on the exact same iPhone, the chart library no longer renders anything.

Things that I have attempted:

  1. watchman watch-del-all && rm -rf $TMPDIR/react-native-packager-cache-* && rm -rf $TMPDIR/metro-bundler-cache-* && rm -rf node_modules/ && npm cache clean --force && npm install && npm start -- --reset-cache

  2. expo start -c

  3. Delete Expo iOS client app and reinstall

  4. npm install --save expo to update expo npm package

  5. Revert to an other version of my code that is known to render the chart properly, and run expo start

Unfortunately, none of these worked. The problem persists and the chart is still not being rendered. What do you think is causing this problem?

  1. SDK Version: 34.0.0
  2. Platforms(Android/iOS/web/all): iOS 12.4.1
  3. Expo version:
1 Like

I have been having the exact same issue as well. WebView in Expo 34 hangs on any device from which I run the Expo client from, both physical and simulator.

I suspect this is an iOS 13+ or xCode 11 issue, as things started breaking around then.

Expo 35 fixes the WebView on these platforms, but introduces some other issues, like headers not persisted beyond the initial page load in WebView, and WebView no longer being able to load in the background when using bottom tab navigator

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.