Upgrading to Expo 31 - Requires Babel "^7.0.0-0", but was loaded with "6.26.3"

Please help. I’ve been working on this for days…

/Users/]/Documents/-dev/src/App.js: Requires Babel “^7.0.0-0”, but was loaded with “6.26.3”. If you are sure you have a compatible version of @babel/core, it is likely that something in your build process is loading the wrong version. Inspect the stack trace of this error to look for the first entry that doesn’t mention “@babel/core” or “babel-core” to see what is calling Babel. (While processing preset: “/Users//Documents/-dev/node_modules/babel-preset-expo/index.js”)


My dev dependencies look like this now:

“devDependencies”: {
@babel/core”: “^7.0.0”,
@babel/cli”: “^7.0.0”,
@babel/plugin-proposal-decorators”: “^7.1.6”,
“babel-core”: “^7.0.0-bridge.0”,
“babel-eslint”: “^9.0.0”,
“babel-preset-react-app”: “^6.1.0”,
“eslint”: “^4.19.1”,
“eslint-config-airbnb”: “^16.1.0”,
“eslint-config-react-app”: “^2.1.0”,
“eslint-plugin-flowtype”: “2.39.1”,
“eslint-plugin-import”: “^2.12.0”,
“eslint-plugin-jsx-a11y”: “^5.1.1”,
“eslint-plugin-react”: “^7.9.1”,
“react-test-renderer”: “16.6.0-alpha.8af6728”

I tried asking here: https://github.com/expo/expo/issues/2566

I have no idea where to go from here…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.