Trying to uninstall expo-cli - no success


I am trying to upgrade to latest version of expo-cli (i.e. 3.0.2) and even though it seems to work, when checking version I still get 2.21.2

To solve, I have removed expo-cli using
npm -g uninstall expo-cli

I have also removed folder ~/.cache/expo/

but still getting version output 2.21.2 when checking with expo -V
I have tried with sudo npm -g uninstall expo-cli but same result.

yarn global list or sudo yarn global list doesn’t give me anything

As I am working on Ubuntu 18.04 I’ve checked using dpkg -l but there is no expo-cli package installed there either…

My question:
How can I make sure expo-cli is removed to re-install correctly the new version?
What am I missing here?

Thanks in advance

Most likely you have installed expo-cli using yarn and npm. You are updating with npm but version form yarn is first in PATH. Just remove it from yarn.
It’s possible that it’s note yarn but two different node/npm installed in your system.

1 Like

thanks wkozyra for you answer and pointing to $PATH

yarn is not mentioned there but I could see that the command expo was calling files from /usr/bin/

After removing this from PATH I could access the right installation of expo-cli

Thanks again!


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.