Standalone app crashes (expo-updates?)

Hi, I’m stuck with a problem that seems related to expo-updates after ejecting my app to the bare workflow.

It works fine in the iOS Simulator but after building and uploading to TestFlight the app crashes immediately after starting.

Crash logs give me this error:
Last Exception Backtrace:
0 CoreFoundation 0x187622a48 __exceptionPreprocess + 220 (NSException.m:199)
1 libobjc.A.dylib 0x187349fa4 objc_exception_throw + 56 (
2 shinner 0x10046f5f4 __46+[EXUpdatesEmbeddedAppLoader embeddedManifest]_block_invoke + 484 (EXUpdatesEmbeddedAppLoader.m:0)

This is what my AppDelegate.m looks like: /** * Copyright (c) Facebook, Inc. and its affiliates. * * This source cod -
AppDelegate.h: /** * Copyright (c) Facebook, Inc. and its affiliates. * * This source cod -
package.json: { "private": true, "scripts": { "start": "react-native start", " -

I’ve tried disabling updates with EXUpdatesEnabled set to false in Expo.plist, but it still crashes with the same error.

I’ve followed this guide to build the app (never used XCode before),

I’m eternally grateful for any pointers. Is my problem related to XCode build configuration, AppDelegate or configuration for expo-updates, something else? What do you think?

Solved this by running “expo publish” after ejecting, which filled the previously empty app.bundle and app.manifest in /ios/project/Supporting

(This is also documented onthe GitHub page for expo-updates under the heading “Embed an initial update”)

Having the same issue. I’ve tried running expo publish a few times now and my manifest and bundle are also filled in. Any ideas on this? Thanks.

There’s another thread with a similar issue. Maybe that can help you?