[SOLVED] Expo SKD 32.0.0 fails with error (Trying to register two views with the same name GestureHandlerRootView)

I upgreded to EXPO SDK 32.0.0. Now app fails on startup with error:

Tried to register two views with the same name GestureHandlerRootView.

There is no any linked libraries.

My npm packages:

"@expo/vector-icons": "^9.0.0",
		"aws-amplify": "^1.1.17",
		"aws-amplify-react-native": "^2.1.5",
		"expo": "^32.0.0",
		"react": "16.5.0",
		"react-native": "https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz",
		"react-native-check-box": "^2.1.7",
		"react-native-datepicker": "^1.7.2",
		"react-native-hr-plus": "^1.0.6",
		"react-native-material-menu": "^0.4.2",
		"react-native-material-textfield": "^0.12.0",
		"react-native-segmented-control-tab": "^3.3.1",
		"react-native-svg-charts": "^5.2.0",
		"react-native-swiper": "^1.5.14",
		"react-navigation": "^3.0.9",
		"react-redux": "^6.0.0",
		"redux": "^4.0.1",
		"redux-thunk": "^2.3.0",
		"styled-components": "^4.1.3"


we can see that threre is two dependencies react-native-gesture-handler

Any solutions?

I updated react-navigation. The latest version use react-native-gesture handler 1.0.12 (exactly as expo uses). Nothing changed. Also I was trying to use resolutions. Didn’t help.

delete your package-lock.json or yarn.lock, delete node_modules, run npm install or yarn again

Thanks. It helped!

1 Like

Glad you got it figured out, @rapture112. Going to close this as it has been solved.