react-native-vision-camera builds no longer work in managed flow with expo48

previously I was able to use react-native-vision-camera package with expo managed flow on expo sdk 47. however after upgrading to expo 48 I keep getting this build error when I am trying to build on android:

Execution failed for task ':react-native-vision-camera:compileReleaseKotlin'.
> A failure occurred while executing org.jetbrains.kotlin.compilerRunner.GradleCompilerRunnerWithWorkers$GradleKotlinCompilerWorkAction

Any suggestions for this issue without dropping the managed flow?


Hi @nuraqas

That’s not enough info to go on. Look further up in the logs. You’ll probably see something similar to:

Task :app:blah FAILED

That should give you more details

Thanks for your reply, The issue is solved now, but I ran through something else. dev Builds now succeed for android and ios, Staging builds succeed for both platforms but I have a runtime error on ios and the app crashes, after connecting a real device and trying to read the logs I get the following error on console before the crash:
" Unhandled JS Exception: Invariant Violation: “main” has not been registered. This can happen if:

  • Metro (the local dev server) is run from the wrong folder. Check if Metro is running, stop it and restart it in the current project.

  • A module failed to load due to an error and AppRegistry.registerComponent wasn’t called., js engine: hermes"

also please note that package.json is as follows:

  "private": true,
  "version": "1.0.0",
  "main": "index.js",
  "scripts": {
    "start": "expo start --dev-client",
    "android": "expo run:android",
    "ios": "expo run:ios",
    "web": "expo start --web",
    "eject": "expo eject"
  "dependencies": {
    "@babel/core": "^7.19.3",
    "@expo/config-plugins": "~6.0.0",
    "@react-native-async-storage/async-storage": "1.17.11",
    "@react-native-community/datetimepicker": "6.7.3",
    "@react-native-community/masked-view": "^0.1.10",
    "@react-native-firebase/analytics": "^16.5.0",
    "@react-native-firebase/app": "^16.5.0",
    "@react-navigation/drawer": "^6.3.0",
    "@react-navigation/native": "^6.1.6",
    "@react-navigation/stack": "^6.3.16",
    "@sentry/react-native": "4.15.2",
    "axios": "^0.21.1",
    "deprecated-react-native-prop-types": "^2.3.0",
    "expo": "^48.0.0",
    "expo-application": "~5.1.1",
    "expo-barcode-scanner": "~12.3.2",
    "expo-build-properties": "~0.6.0",
    "expo-camera": "~13.2.1",
    "expo-dev-client": "~2.2.1",
    "expo-device": "~5.2.1",
    "expo-file-system": "~15.2.2",
    "expo-image-loader": "~4.1.1",
    "expo-image-manipulator": "~11.1.1",
    "expo-image-picker": "~14.1.1",
    "expo-linear-gradient": "~12.1.2",
    "expo-linking": "~4.0.1",
    "expo-localization": "~14.1.1",
    "expo-mail-composer": "~12.1.1",
    "expo-permissions": "~14.1.1",
    "expo-screen-orientation": "~5.1.1",
    "expo-splash-screen": "~0.18.2",
    "expo-status-bar": "~1.4.4",
    "expo-store-review": "~6.2.1",
    "expo-updates": "~0.16.4",
    "expo-web-browser": "~12.1.1",
    "lottie-react-native": "5.1.4",
    "prop-types": "^15.6.2",
    "react": "18.2.0",
    "react-dom": "18.2.0",
    "react-native": "0.71.8",
    "react-native-elements": "^2.3.2",
    "react-native-gesture-handler": "~2.9.0",
    "react-native-modal": "^13.0.1",
    "react-native-paper": "^4.12.3",
    "react-native-reanimated": "~2.14.4",
    "react-native-render-html": "^6.3.1",
    "react-native-safe-area-context": "4.5.0",
    "react-native-screens": "~3.20.0",
    "react-native-svg": "13.4.0",
    "react-native-tab-view": "^2.15.2",
    "react-native-vector-icons": "^7.1.0",
    "react-native-vision-camera": "^2.13.0",
    "react-native-web": "~0.18.11",
    "react-native-webview": "11.26.0",
    "react-redux": "^7.2.6",
    "recoil": "^0.7.5",
    "redux-thunk": "^2.4.1",
    "sentry-expo": "~6.2.0"
  "devDependencies": {
    "@babel/core": "^7.20.0",
    "babel-plugin-transform-inline-environment-variables": "^0.4.4",
    "babel-preset-expo": "^9.3.0"

and running expo doctor gives me the following warning:
Expected package @expo/config-plugins@~6.0.0
Found invalid:

and when running npm why command, many packages appeared ,howver its not possible to update these packages as some of them require expo 49

also please keep in mind that these issues only appeared after expo 48 upgrade

please let me know if you have any suggestions