Permissions.askAsync for Notifications is not resolving

Currently running a detached application using expokit, Originally started on SDK 27, now updated to SDK 31. Issue is occurring on iOS.

After running getAsync(Permissions.NOTIFICATIONS) I am returned undetermined and so I run askAsync(Permissions.NOTIFICATIONS).

When askAsync runs on a device for the first time (clean install) it appropriately brings up the enable notification alert. However, on subsequent runs it simply does not resolve, does not even throw an error. I understand that iOS doesn’t allow showing this popup after a user has declined, but askAsync should still resolve in some way.

I have found github issues where supposedly this was fixed, however this issues still persists on our project. In the mean time I have set a timeout on askAsync, but this is not the most ideal solution.

Hey @strongmachine,

Can you try throwing together a Snack that reproduces this behavior so we can test it out on our end?



On simulator the methods always resolve with undetermined, so it really isn’t reproducible. This case needs to be tested on a real device.

Yeah, I’ll be testing it on a iPhone 7s and Galaxy S8 once I get on better wifi. Currently on a coach bus and wifi is pretty rough. Thanks for the Snack!

1 Like

Any update on this - I am trying to get permissions for location as well and it does not resolve at all.

Thank you

I think Permissions.askAsync in general is not resolving either for Notifications or Locations. Haven’t tried anything else yet - this is on iOS

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.