On SDK 41: Your project is in SDK version >= 33.0.0, but the expo package version seems to be older.

Please provide the following:

  1. SDK Version: 41
  2. Platforms(Android/iOS/web/all): all

I just ran expo-upgrade and I am now seeing the following warning when I run expo start:
Your project is in SDK version >= 33.0.0, but the expo package version seems to be older.
The process then gets stuck on info Launching Dev Tools... without progressing.

I have tried to delete the node_modules folder and run npm install again with no success.

I have done expo upgrade several times to try and repair the installation, also with no success.

What should I do to fix this message?

Something that might have to do with it. When I run expo upgrade, I also get this message:

√ You are already using the latest SDK version. Do you want to run the update anyways? This may be useful to ensure that all of your packages are set to the correct version. ... yes

√ Would you like to upgrade the Expo app in the Android emulator? ... no

√ Validated configuration.
√ No additional changes necessary to app.json config.
× Failed to upgrade JavaScript devDependencies: jest-expo@^41.0.0 @babel/core@~7.9.0 @types/react@~16.9.35 babel-preset-expo@8.3.0 @types/react-native@~0.63.2 @expo/webpack-config@~0.12.63
1 Like

Hey @divone, can you share the package.json and app.json for the project?

Sure thing. There they are.

FYI: I changed
"expo": "^41.0.0" to "expo": "^41.0.1" just to try, but it doesn’t work in any case.


  "main": "node_modules/expo/AppEntry.js",
  "homepage": "/static/web-build",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "test": "jest --watchAll"
  "jest": {
    "preset": "jest-expo"
  "dependencies": {
    "@chardskarth/react-gateway": "^3.0.3",
    "@expo/vector-icons": "^12.0.0",
    "@react-native-async-storage/async-storage": "^1.13.0",
    "@react-native-community/checkbox": "^0.5.3",
    "@react-native-community/clipboard": "^1.2.3",
    "@react-native-community/hooks": "^2.6.0",
    "@react-native-community/masked-view": "0.1.10",
    "@react-native-picker/picker": "1.9.11",
    "@react-navigation/bottom-tabs": "^5.8.0",
    "@react-navigation/drawer": "^5.9.0",
    "@react-navigation/material-bottom-tabs": "^5.2.16",
    "@react-navigation/native": "^5.7.3",
    "@react-navigation/stack": "^5.9.0",
    "@react-navigation/web": "^1.0.0-alpha.9",
    "@reduxjs/toolkit": "^1.4.0",
    "expo": "^41.0.1",
    "expo-app-loading": "^1.0.3",
    "expo-asset": "~8.3.1",
    "expo-clipboard": "~1.0.2",
    "expo-constants": "~10.1.3",
    "expo-error-recovery": "~2.1.0",
    "expo-font": "~9.1.0",
    "expo-image-picker": "~10.1.4",
    "expo-linking": "~2.2.3",
    "expo-notifications": "~0.11.6",
    "expo-permissions": "~12.0.1",
    "expo-splash-screen": "~0.10.2",
    "expo-updates": "~0.5.4",
    "expo-web-browser": "~9.1.0",
    "moment": "^2.29.0",
    "moment-countdown": "0.0.3",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-inlinesvg": "^2.2.2",
    "react-medium-image-zoom": "^4.3.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-41.0.0.tar.gz",
    "react-native-gesture-handler": "~1.10.2",
    "react-native-paper": "^3.11.0",
    "react-native-reanimated": "~2.1.0",
    "react-native-redash": "^14.2.4",
    "react-native-safe-area-context": "3.2.0",
    "react-native-screens": "~3.0.0",
    "react-native-svg": "12.1.0",
    "react-native-svg-transformer": "^0.14.3",
    "react-native-web": "~0.13.12",
    "react-native-web-hooks": "^3.0.1",
    "react-native-webview": "11.2.3",
    "react-redux": "^7.2.1",
    "redux": "^4.0.5",
    "resize-observer-polyfill": "^1.5.1",
    "sentry-expo": "^3.1.0",
    "tinycolor2": "^1.4.1"
  "devDependencies": {
    "@babel/core": "^7.11.6",
    "@expo/webpack-config": "^0.12.16",
    "@types/react": "~16.9.35",
    "@types/react-native": "~0.63.2",
    "babel-plugin-inline-import": "^3.0.0",
    "babel-preset-expo": "^8.3.0",
    "jest-expo": "^39.0.0"
  "private": true


  "expo": {    
    "name": "Role Gate",
    "slug": "rolegate-app",
    "privacy": "public",
    "platforms": [
    "version": "1.0.4",
    "orientation": "portrait",
    "icon": "./assets/images/icon.png",
    "scheme": "rolegate",
    "backgroundColor": "#151728",
    "splash": {
      "image": "./assets/images/splash_screen2.png",
      "resizeMode": "contain",
      "backgroundColor": "#151728"
    "notification": {
      "icon": "./assets/images/NotificationIcon.png",
      "color": "#151728"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "ios": {
      "supportsTablet": false,
      "bundleIdentifier": "com.LodestarTeam.rolegateapp",
      "buildNumber": "1.0.4",
      "associatedDomains": ["applinks:rolegate.com"]
    "android": {
      "package": "com.LodestarTeam.rolegateapp",
      "versionCode": 36,
      "icon": "./assets/images/icon.png",
      "adaptiveIcon": {
        "foregroundImage": "./assets/images/Adaptive_Icon_foreground.png",
        "backgroundImage": "./assets/images/Adaptive_Icon_background.png"
      "useNextNotificationsApi": true,
      "googleServicesFile": "./google-services.json",
      "permissions": [],
          "autoVerify": true,
          "action": "VIEW",
          "data": [
              "scheme": "https",
              "host": "*.rolegate.com"
          "category": [
    "androidStatusBar": {
      "barStyle": "light-content"
    "hooks": {
      "postPublish": [
          "file": "sentry-expo/upload-sourcemaps",
          "config": {
            "organization": "lodestar-team",
            "project": "role-gate-app",
            "authToken": "xxxx"

same issue, following here if there is a solution. Also on SDK41, and the project was only created on SDK38, so not sure where SDK 33 is coming from…

1 Like

Same issue here.

1 Like

I just updated to the latest expo-cli (which in turn made me update my version of NodeJs) and now the error doesn’t show anymore.

I had this issue recently and solved it by deleting the node_modules folder (rm -rf node_modules) and then running npm install (npm users) or yarn install (yarn users);

For me the issue was probably due to the fact that I was switching back and forth between two branches that had different SDK versions.

1 Like

if you see this warning then something like what @esdrasevt mentioned might be applicable, but likely you need to just upgrade the expo-cli version

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.