New error building Android in EAS

Before posting your question, make sure you’ve read the documentation for both EAS Build & Submit.

If your Android or iOS build is failing- make sure you do your own research on the error message first before posting (this will give you a better understanding, and you might even find that someone else has already solved the issue!) It is not up to the Expo team to debug your project or build.

In your post, please share:

  • Whether you are bare or managed workflow - managed
  • Your eas-cli version - 3.13.3
  • What you have tried so far - resubmitting build w/clearing the cache

Yesterday, before I upgraded to cli 3.13.3, I successfully built my app for Android. After the upgrade, with only minor changes to a few lines of code, no dependency changes, I get the following error:


Execution failed for task ':react-native-nodemediaclient:generateReleaseRFile'.


> Could not resolve all files for configuration ':react-native-nodemediaclient:releaseCompileClasspath'.


   > Failed to transform NodeMediaClient-Android-2.9.23.aar (com.github.NodeMedia:NodeMediaClient-Android:2.9.23) to match attributes {artifactType=android-symbol-with-package-name, org.gradle.category=library, org.gradle.dependency.bundling=external, org.gradle.libraryelements=aar, org.gradle.status=release, org.gradle.usage=java-api}.


> Could not find NodeMediaClient-Android-2.9.23.aar (com.github.NodeMedia:NodeMediaClient-Android:2.9.23).


        Searched in the following locations:



Any ideas?

Hi @debownor66

This looks like a problem with Jitpack or node media client.

If I try to fetch that URL I get a “Not found” error

Thanks for trying to find it. What I don’t understand is why it’s failing now, and it wasn’t failing in prior builds. Nothing changed in my code or configuration.

Not sure, but if I go here:

I see versions 3.1.8 and higher listed. So maybe they removed older versions?

This doesn’t seem to be caused by changes in your code or on Expo’s servers.

Very strange!

When I read your last message I checked again and I was still getting a “Not found” error when trying to fetch that URL.

Then I started looking around on and found the >= 3.1.8 versions.

Then I clicked on the 3.1.8 build log and changed the version to 2.9.23 and was surprised to see that it worked! Then I removed the build.log from the end of the URL and got a list of files, including the .aar file!

Then I tried fetching it again and this time it worked!

Anyway, it seems like there was something weird going on on At the moment I can access the file. See if your build works now?

It works now! Thanks for your help.

1 Like