My development environment has been down since latest upgrade

I had a lot of trouble with the new upgrade of Expo / React Native …solved a lot and now I got this one …and I’m stuck …

Unable to resolve “@babel/runtime/helpers/objectSpread” from “node_modules@react-navigation\core\lib\module\StateUtils.js”

Any sugestions?

But it’s also like nothing works after an upgrade …can’t even make a new sample app and make it run …is there a way around? Installing old versions? The Expo phone client does’nt work with older versions of the environment.

Hi @caminoninja! Sorry you’re having some trouble with upgrading, let me try and help out

First of all, if you’re in a time crunch and need to run your apps that are on SDKs < 31, here are links to older versions of the Expo client, with which you can run SDKs 26-30:



Next, I can’t say I’ve seen that error before, so we’ll work on the larger problem of your dev environment first. What version of the expo-cli are you using? If you just expo init a new blank project, and run expo start, what errors exactly are you getting?

It got solved …do not really know how …I’m up and running again …reinstalled Node.js, Expo, and upgraded node_modules.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.