iOS13 crashes instantly for some (EXC_BAD_ACCESS (SIGBUS)

Not clear if this is same bug:

Also have reports of a crash on iOS 13.1, SDK 34, iPhone 11 Pro Max. Here’s the crashlog from xcode:

Hello, for expokit with SDK34,
What do i need to do to resolve this issue?
I just need to update the expo-cli and rebuild the binary in Xcode 11?
or I should also upgrade expo, expokit , RN minor version in npm?

1 Like

I want to know that too (in the same situation, expokit with SDK34)

please tell us what to do.

Hi there-- for expokit, you’ll need to update the ExpoKit tag in your Podfile to ios/2.12.5, rerun pod install and then rebuild your binary in Xcode. (For SDK 33, use tag ios/2.11.5).

1 Like

Thank you for your advice but your solution didn’t well.

The quote of my package.json is like this

“react-native”: “”,

And I think this source doesn’t include your commit to solve this crash issue.

I want you to show me your idea about this.
also I want to know additional solution if you have any information.

Hi there - you don’t need to have the Objective C fixes in your node_modules, only in your Pods folder. If you follow the instructions I posted above, that should be enough. Have you tried following those instructions and are still encountering the same crash?

1 Like

Thank you for your comment!

Sure. I have tried your instructions twice and my colleague has too.
I wonder if my Podfile is a bit different from yours because I have upgraded my app from expokit30 to expokit34

My Podfile is like this.

source ''
platform :ios, '10.0'

target 'xxxxxxxxxxxx' do
  pod 'Firebase/Core'
  pod 'ExpoKit',
    :git => "",
    :tag => "ios/2.12.5",
    :subspecs => [
    :inhibit_warnings => true

  pod 'React',
    :path => "../node_modules/react-native",
    :inhibit_warnings => true,
    :subspecs => [
  pod 'yoga',

After I put your commited files(RCTActionSheetManager.m, RCTReconnectingWebSocket.m) into my node_module/react-native directory, my app’s crash was fixed.


Ah, sorry for the confusion. I’ve gone ahead and tagged versions sdk-34.0.2 and sdk-33.0.1 of expo’s react-native fork, which have the bugfix. You can go ahead and install those if you’re using expokit. (Note that you also still need to follow the podfile instructions I posted above in order to get all the fixes!)


Any news about it? My app facing this problem too, upgraded to 35 but users still report crashed on IOS 13 :frowning:

I upgraded to SDK 35 and using managed version. But still crashes on ios 13

@ngocthua92 do you have a stacktrace for the crash?

So sorry, I dont have stacktrace. It’s users report to me, about 10 users reported, but my device is not crashed :frowning:

Updated: I know how to get crash log, and here my log:

@ngocthua92 this looks to be WebView related, I’d do a pass over any code in your app that’s using a WebView to try and reproduce the issue. I don’t think this is related to the iOS 13 crash that’s the original subject of this thread.

1 Like

Yes, I know it’s other error code. Thanks for your support and looking forward to a solution from you!

To clarify, looking over your WebView usage is what I would suggest you do to try to pinpoint the cause of the crash. If you find a reproducible way to cause this crash, feel free to open an issue on GitHub and we’ll investigate further at that point. Sorry for the confusion!

1 Like

Dont mind. But it’s so weird, my app do not use any webview, so the first thing I thinking is about ads-mod, I show a fullscreen Interstitial ads when user open app. I will remove it and try to publish new version. I will give you feedback when I have result. Thanks for you support. Love Expo Team :smiley:

Hi guys do you have any updates on this? We upgraded to SDK 35 yesterday and are still experiencing crashes on iOS 13. Is there a workaround?

Unfortunately, not yet. I’m still looking someone can resolve it for me :(. Please helppppp!

Did you found the solution? Can you share me? My app still crashes :frowning: