iOS Status Bar orientation

I am trying to lock screen orientation to landscape right. In my app.json I have specified "orientation": "landscape" but that did not seem to lock orientation for the app. I then used Expo.ScreenOrientation.allow(Expo.ScreenOrientation.Orientation.LANDSCAPE_RIGHT); which worked. Now I am noticing strange behavior in which the app stays locked but the status bar is still rotating.

1 Like

hi, what version of expo are you using? Can you provide a small reproducible test case?

Had this same thing happen to me. It occurs off and on. There’s a related issue for it.

I also experienced the same case as in the GitHub issue, it is on and off for me. After creating a snack the behavior was gone. It went away in my app as well. Will report back if I notice it again and have more info.

Version info: “expo”: “^23.0.0”, “react”: “16.0.0”, “react-native”: “https://github.com/expo/react-native/archive/sdk-23.0.0.tar.gz”, and the latest version of Expo XDE (23.0.0).

@mc10 – let’s continue handling this issue on the GitHub issue since we keep track of that internally too. You should be able to receive support there as you need. :smile:

Did SDK 39 bring back the issue? It seems so.

1 Like

Yep, this issue is back with SDK39 …

hey @mobshed did you find any solution for this ?

No. Apparently it’s a bug.

@notbrent are you guys working on a fix for that ? it seems to be related to sdk39 since we didn’t have the issue on sdk38

are you sure it is a sdk 39 issue? is it perhaps introduced with ios 14? the issue report you linked to indicates that it has been happening since sdk 37 and appears to be a bug. i don’t have time to investigate this at the moment but if you can help out that’d be great

There are 2 variables here: SDK Version and iOS Version. SDK 38 + iOS 13 was fine. SDK 39 + iOS 14 is not. Has someone tried SKD 39 + iOS 13 by any chance?

Yesterday I opened the Reddit app on my iOS 14 device and, weirdly enough, the status bar was rotating, although the app was still in portrait mode… iOS 14 issue then?

@mobshed did you find any solution for this ?

nope. sorry.

Edit: Same issue on iOS13. Could be SDK39 or the expo client app, not sure