iOS build in CI

We have a Gitlab CI configuration that builds both our Android and iOS archives. It used to work fine until Apple forced me to enable 2FA on the CI account.

I tried to configure fastlane as described in the documentation to use an existing session so that it wouldn’t ask for 2FA when the build is run on the CI server. However, when I do this, I get the following message:

Available session is not valid any more. Continuing with normal login.

When this happens, it attempts 2FA and fails. So far I tried:

  • Setting up the FASTLANE_SESSION environment variable as described in the doc above
  • Setting the ~/.fastlane/spaceship/<username>/cookie file with a copy of what I have on my laptop

What can I do to make that build work in CI?

Expo diagnostics on my CI server:

$ expo diagnostics
$ Expo CLI 3.23.3 environment info:
$ System:
$ OS: Linux 4.19 Debian GNU/Linux 9 (stretch) 9 (stretch)
$ Shell: 4.4.12 - /bin/bash
$ Binaries:
$ Node: 10.22.0 - /tmp/yarn–1596727642846-0.41715127026078536/node
$ Yarn: 1.22.4 - /tmp/yarn–1596727642846-0.41715127026078536/yarn
$ npm: 6.14.6 - /usr/local/bin/npm
$ npmPackages:
$ expo: ^38.0.0 => 38.0.9
$ react: 16.11.0 => 16.11.0
$ react-native: => 0.62.2
$ react-navigation: 4.4.0 => 4.4.0

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.