iOS build fails. Error: Process exited with non-zero code: 1

iOS build fails both with expo and turtle with Error: Process exited with non-zero code: 1

I tried removing and recreating certificates and profile provisions multiple times, still getting the same error.

this are the logs:

Were you recreating certificates by yourself or did this via expo-cli?

I created them by myself, because trying to let expo handle the process fails with another error.

What is that another error?

@jakubste, this is the error it doesn’t even go to expo for build

17:32:00] Error while gathering & validating credentials
[17:32:00] Error: Reason: Unknown reason, raw: {
  "type": "Faraday::ParsingError",
  "message": "757: unexpected token at 'Bad Request'",
  "backtrace": [
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/json-1.8.2/lib/json/common.rb:155:in `parse'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/json-1.8.2/lib/json/common.rb:155:in `parse'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response/parse_json.rb:11:in `block in <class:ParseJson>'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:51:in `call'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:51:in `parse'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:40:in `process_response'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:33:in `block in call'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/response.rb:61:in `on_complete'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:31:in `call'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/rack_builder.rb:143:in `build_response'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/connection.rb:387:in `run_request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/connection.rb:175:in `post'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:689:in `block in send_request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:524:in `with_retry'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:688:in `send_request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:576:in `request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/portal/portal_client.rb:531:in `create_certificate!'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/portal/certificate.rb:301:in `create!'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/app/fetch_push_cert.rb:24:in `block in <main>'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/app/funcs.rb:4:in `with_captured_stderr'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/app/fetch_push_cert.rb:13:in `<main>'"
  ]
}
[17:32:00] Reason: Unknown reason, raw: {
  "type": "Faraday::ParsingError",
  "message": "757: unexpected token at 'Bad Request'",
  "backtrace": [
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/json-1.8.2/lib/json/common.rb:155:in `parse'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/json-1.8.2/lib/json/common.rb:155:in `parse'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response/parse_json.rb:11:in `block in <class:ParseJson>'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:51:in `call'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:51:in `parse'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:40:in `process_response'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:33:in `block in call'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/response.rb:61:in `on_complete'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday_middleware-0.12.2/lib/faraday_middleware/response_middleware.rb:31:in `call'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/rack_builder.rb:143:in `build_response'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/connection.rb:387:in `run_request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/faraday-0.15.2/lib/faraday/connection.rb:175:in `post'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:689:in `block in send_request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:524:in `with_retry'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:688:in `send_request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/client.rb:576:in `request'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/portal/portal_client.rb:531:in `create_certificate!'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/vendor/ruby/2.2.0/gems/fastlane-2.97.0/spaceship/lib/spaceship/portal/certificate.rb:301:in `create!'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/app/fetch_push_cert.rb:24:in `block in <main>'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/app/funcs.rb:4:in `with_captured_stderr'",
    "/usr/local/lib/node_modules/expo-cli/node_modules/@expo/traveling-fastlane-darwin/traveling-fastlane-1.6.0-osx/lib/app/fetch_push_cert.rb:13:in `<main>'"
  ]
}```

so I figured out the first fail, it was hidden between the logs Provisioning profile is not an "iOS Ad Hoc" profile. So I recreated an Ad Hoc profile and tried a build with that, and now it just hangs on expo and fails with the same error on turtle.

I really don’t know what to do anymore :frowning:

Are you using Apple Developer Enterprise account or just regular one?

@jakubste, it’a paid apple developer account, Program Type Apple Developer Program

It looks like you’re trying to generate ad hoc app? Did you select something like this during certificates creation? Expo does not support building an app with ad hoc certificate.

I was using iOS App Development certificate, I tried with an ad hoc certificate because the error logs told so.

So I just tried using an ad hoc certificate, but until now, for the error logs I posted initially I was using an iOS App Development certificate

OK. When you’re clicking “+” on site with iOS certificates, you need to select “App Store and Ad Hoc”. This will create a distribution certificate, which our builders can handle. Also just to be sure - recreate provisioning profile.

@jakubste, thank you lots ! so I already tried that a little bit before, and the build seemed to hang for a really long time, now it seems that the build actually succedeed on expo after a really long time, but it still fails on turtle unfortunately, I really need to use turtle for the builds, mainly because of this reason.

this is the error logs:

Nov 21 18:06:18 turtle[36908] INFO:  Error Domain=IDEFoundationErrorDomain Code=1 "Failed to verify bitcode in ExpoKitApp.app/ExpoKitApp:
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  error: Platform iOS is not supported
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  " UserInfo={NSLocalizedDescription=Failed to verify bitcode in ExpoKitApp.app/ExpoKitApp:
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  error: Platform iOS is not supported
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  }
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ** EXPORT FAILED **
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.16]: Exit status: 70
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  +---------------+-------------------------+
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  |            Build environment            |
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  +---------------+-------------------------+
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  | xcode_path    | /Applications/Xcode.app |
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  | gym_version   | 2.108.0                 |
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  | export_method | ad-hoc                  |
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  | sdk           | iPhoneOS11.4.sdk        |
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  +---------------+-------------------------+
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  INFO [2018-11-21 18:06:18.19]:
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: Looks like fastlane ran into a build/archive error with your project
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: It's hard to tell what's causing the error, so we wrote some guides on how
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: to troubleshoot build and signing issues: https://docs.fastlane.tools/codesigning/getting-started/
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: Before submitting an issue on GitHub, please follow the guide above and make
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: sure your project is set up correctly.
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: fastlane uses `xcodebuild` commands to generate your binary, you can see the
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: the full commands printed out in yellow in the above log.
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  ERROR [2018-11-21 18:06:18.19]: Make sure to inspect the output above, as usually you'll find more error information there
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  INFO [2018-11-21 18:06:18.19]:
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/fastlane_core/lib/fastlane_core/ui/interface.rb:163:in `build_failure!': [!] Error packaging up the application (FastlaneCore::Interface::FastlaneBuildFailure)
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/fastlane_core/lib/fastlane_core/ui/ui.rb:17:in `method_missing'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/error_handler.rb:112:in `handle_package_error'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/runner.rb:138:in `block in package_app'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/fastlane_core/lib/fastlane_core/command_executor.rb:89:in `call'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/fastlane_core/lib/fastlane_core/command_executor.rb:89:in `execute'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/runner.rb:134:in `package_app'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/runner.rb:27:in `run'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/manager.rb:19:in `work'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/commands_generator.rb:44:in `block (2 levels) in run'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in `call'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in `call'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:153:in `run'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/commander-fastlane-4.4.6/lib/commander/runner.rb:476:in `run_active_command'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/fastlane_core/lib/fastlane_core/ui/fastlane_runner.rb:76:in `run!'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/commander-fastlane-4.4.6/lib/commander/delegates.rb:15:in `run!'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/commands_generator.rb:75:in `run'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/gym/lib/gym/commands_generator.rb:15:in `start'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/fastlane/lib/fastlane/cli_tools_distributor.rb:100:in `take_off'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/lib/ruby/gems/2.2.0/gems/fastlane-2.108.0/bin/fastlane:23:in `<top (required)>'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/bin/fastlane:22:in `load'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] INFO:  	from /Users/teo/.fastlane/bin/bundle/bin/fastlane:22:in `<main>'
  buildPhase: "building and signing IPA"
  source: "stdout"
Nov 21 18:06:18 turtle[36908] ERROR: Error: Process exited with non-zero code: 1
    at ChildProcess.child.on (/usr/local/lib/node_modules/turtle-cli/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
    at ChildProcess.emit (events.js:182:13)
    at ChildProcess.EventEmitter.emit (domain.js:442:20)
    at maybeClose (internal/child_process.js:961:16)
    at Socket.stream.socket.on (internal/child_process.js:380:11)
    at Socket.emit (events.js:182:13)
    at Socket.EventEmitter.emit (domain.js:442:20)
    at Pipe._handle.close [as _onclose] (net.js:595:12)
Nov 21 18:06:18 turtle[36908] INFO:  delete keychain...
  buildPhase: "deleting keychain"
Nov 21 18:06:18 turtle[36908] INFO:  deleting keychain...
  buildPhase: "deleting keychain"
Nov 21 18:06:22 turtle[36908] INFO:  done deleting keychain
  buildPhase: "deleting keychain"
Nov 21 18:06:22 turtle[36908] ERROR: Failed to build standalone app: Process exited with non-zero code: 1
Nov 21 18:06:22 turtle[36908] ERROR: Error: Process exited with non-zero code: 1
    at ChildProcess.child.on (/usr/local/lib/node_modules/turtle-cli/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
    at ChildProcess.emit (events.js:182:13)
    at ChildProcess.EventEmitter.emit (domain.js:442:20)
    at maybeClose (internal/child_process.js:961:16)
    at Socket.stream.socket.on (internal/child_process.js:380:11)
    at Socket.emit (events.js:182:13)
    at Socket.EventEmitter.emit (domain.js:442:20)
    at Pipe._handle.close [as _onclose] (net.js:595:12)

You mean using turtle-cli on your CI? Because we are also using turtle :wink:

yes, using turtle-cli both on ci and local.

Judging by “error: Platform iOS is not supported” I suppose you might put somewhere in the configuration “iOS” instead of “ios”? Could you verify that theory?

@jakubste I just checked everywhere in the project, it’s lowercase “ios” everywhere in the config files.

Hey @teodruta,
what version of xcode do you have?

@dsokal, Version 9.4.1 (9F2000), yeah I understand now so expo 31 supports only xcode 10 and bigger, but I think that the error message could have been specific in this case. So i downgraded to expo 30 and now when I try to build it locally with turtle I get the error message Failed to build standalone app: Couldn't find app.json, I definitely have the app.json file.

And where (in what directory) do you run turtle build:ios command? Is app.json file there?

yes it was in the same directory, I updated Xcode on my computer and now I get another error.

This is the error and diagnostics.

Thanks a lot !

Nov 22 15:45:00 turtle[13042] INFO:  Cleaning up iOS...
  buildPhase: "configuring NSBundle"
Nov 22 15:45:00 turtle[13042] ERROR: Error: Process exited with non-zero code: 255
    at ChildProcess.child.on (/usr/local/lib/node_modules/turtle-cli/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
    at ChildProcess.emit (events.js:182:13)
    at ChildProcess.EventEmitter.emit (domain.js:442:20)
    at maybeClose (internal/child_process.js:961:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:248:5)
Nov 22 15:45:00 turtle[13042] INFO:  delete keychain...
  buildPhase: "deleting keychain"
Nov 22 15:45:00 turtle[13042] INFO:  deleting keychain...
  buildPhase: "deleting keychain"
Nov 22 15:45:03 turtle[13042] INFO:  done deleting keychain
  buildPhase: "deleting keychain"
Nov 22 15:45:03 turtle[13042] ERROR: Failed to build standalone app: Process exited with non-zero code: 255
Nov 22 15:45:03 turtle[13042] ERROR: Error: Process exited with non-zero code: 255
    at ChildProcess.child.on (/usr/local/lib/node_modules/turtle-cli/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
    at ChildProcess.emit (events.js:182:13)
    at ChildProcess.EventEmitter.emit (domain.js:442:20)
    at maybeClose (internal/child_process.js:961:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:248:5)
  Expo CLI 2.4.0 environment info:
    System:
      OS: macOS 10.14
      Shell: 5.3 - /bin/zsh
    Binaries:
      Node: 10.4.0 - /usr/local/bin/node
      Yarn: yarn install v0.28.4
[1/4] Resolving packages...
success Already up-to-date.
Done in 0.56s. - /usr/local/bin/yarn
      npm: 6.4.1 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    IDEs:
      Android Studio: 3.2 AI-181.5540.7.32.5014246
      Xcode: 10.1/10B61 - /usr/bin/xcodebuild
    npmPackages:
      expo: 30.0.1 => 30.0.1
      react: 16.3.1 => 16.3.1
      react-native: https://github.com/expo/react-native/archive/sdk-30.0.0.tar.gz => 0.55.4
      react-navigation: 2.17.0 => 2.17.0
    npmGlobalPackages:
      expo-cli: 2.4.0

  Diagnostics report:
    https://exp-xde-diagnostics.s3.amazonaws.com/smartup-5783d01d-03fb-4570-834a-25a9140cdc96.tar.gz