I can't use any library that uses linking in an ejected expo project

I ejected my project a few days ago to use so components in Android that weren’t available for expo projects like a background module that can handle notifications but I can’t use a single one. I tried the react-native-background-job, react-native-background-fetch, react-native-background-task but all gave a similiar error message:

[Unhandled promise rejection: TypeError: null is not an object (evaluating 'RNBackgroundFetch.configure')]

Where ‘evaluating X’ had different X for each module. I tried checking if I missed any installation steps but I couldn’t find anything wrong and since it’s for many modules I guess it’s a from a common cause which I can’t solve individually. Thanks in advance for the attention

Hey @danielgb,

Can you try reproducing this with a freshly created Bare project via expo init and take me step by step as to how you are installing and configuring said library?

On a side note, there are background modules available in Expo that are compatible with Android that may satisfy your needs: https://docs.expo.io/versions/v38.0.0/sdk/background-fetch/ https://docs.expo.io/versions/v38.0.0/sdk/task-manager/


I discovered the problem. I was using the expo metro do run the bare workflow with linked components which doesn’t work. Running it with react-native start and react-native run-android did it for me.

Thanks for sharing the solution to your issue, @danielgb.