how to solve this error

Node -v 14.17.6
Expo SDK 42

Error:

moment@2.29.1 ?
react-navigation-drawer@2.7.1 ?
[0] …\node_modules\expo
[0] internal/fs/utils.js:314
[0] throw err;
[0] ^
[0]
[0] Error: EPERM: operation not permitted, symlink ‘…\node_modules\expo’ →
‘C:\Users\usr\Desktop\import\code\mobile\node_modules\expo’
[0] at Object.symlinkSync (fs.js:1210:3)
[0] at symlinkNecessaryPackage (C:\Users\usr\Desktop\import\code
\node_modules\expo-yarn-workspaces\bin\symlink-necessary-packages.js:65:8)
[0] at symlinkNecessaryPackages (C:\Users\usr\Desktop\import\cod
e\node_modules\expo-yarn-workspaces\bin\symlink-necessary-packages.js:17:3)
[0] at Object. (C:\Users\usr\Desktop\import\code\node
_modules\expo-yarn-workspaces\bin\symlink-necessary-packages.js:81:3)
[0] at Module._compile (internal/modules/cjs/loader.js:1072:14)
[0] at Object.Module._extensions…js (internal/modules/cjs/loader.js:1101:10
)
[0] at Module.load (internal/modules/cjs/loader.js:937:32)
[0] at Function.Module._load (internal/modules/cjs/loader.js:778:12)
[0] at Function.executeUserEntryPoint [as runMain] (internal/modules/run_mai
n.js:76:12)
[0] at internal/main/run_main_module.js:17:47 {
[0] errno: -4048,
[0] syscall: ‘symlink’,
[0] code: ‘EPERM’,
[0] path: ‘…\…\node_modules\expo’,
[0] dest: ‘C:\Users\usr\Desktop\import\code\mobile\node_mod
ules\expo’
[0] }
[0] cd mobile && expo-yarn-workspaces postinstall exited with code 1
→ Sending SIGTERM to other processes…
[1] exicube install exited with code 1
error Command failed with exit code 1.
info Visit yarn install | Yarn for documentation about this
command.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.