How to resolve EAS Build Expo Doctor error?

Currently running Expo SDK 48. Am able to build successfully, but have not been able to resolve the following error from the Expo Doctor phase of EAS Build:

Expected package @expo/config-plugins@~6.0.0
  Found invalid:
    (for more info, run: npm why @expo/config-plugins)
  β€’ Upgrade dependencies that are using the invalid package versions.

If I run npm ls @expo/config-plugins, here is the result:

brainiac@1.0.0 /Users/sodiumhalogen/wip/megla-workshop-app
β”œβ”€β”€ @expo/config-plugins@6.0.1
β”œβ”€β”¬ @expo/config@8.0.2
β”‚ └── @expo/config-plugins@6.0.1 deduped
β”œβ”€β”¬ @expo/prebuild-config@6.0.1
β”‚ └── @expo/config-plugins@6.0.1 deduped
β”œβ”€β”¬ @expo/webpack-config@18.0.4
β”‚ └─┬ @expo/config@6.0.20
β”‚   └── @expo/config-plugins@4.1.1
└─┬ expo@48.0.15
  β”œβ”€β”¬ @expo/cli@0.7.1
  β”‚ └── @expo/config-plugins@6.0.1 deduped
  └── @expo/config-plugins@6.0.1 deduped

It looks as if expo/webpack-config@18.04 is utilizing the older version 4.1.1 as a dependency. Is there a way to get EAS to use the expected version 6.0.0, instead?


Hi @sodiumhalogen

I don’t think @expo/webpack-config is needed these days.

1 Like

Thanks for the reply! I removed that package and it did indeed resolve the issue.

1 Like

@wodin for --web @expo/webpack-config still required per Develop for Web - Expo Documentation?

You’re right. Thanks

1 Like

bumping to 18.1.0 (published yesterday) worked for me

1 Like