How to build self-hosted apps locally without expo account and offline (using "turtle-cli --public-url", mobx, react-navigation, "expo managed workflow")?

I’ve been trying to do that (title) and came across few helpful guide like - and some helpful forum relevant entries too.

Kudos and thanks to @RobinCsl of whom, found most relevant and “complete” guide related to this here.

And may be the documentation is lacking or may be the process or may be I’m lacking too. But the builds I was able to successfully make, lacked a few things -

  1. Warning of mobx related to Node.env = production/development (the app is using mobx latest) - I think it is related to But while I run the same app using “expo start” - no warning at all. Strangely, the warning wasn’t removed on downgrading the package… tried clearing cache, etc.

  2. Warning related to providing inline function to component prop in stack-navigator. App is using react-navigation latest. But while running with “expo start” - no warning, even in dev mode.

  3. While the “turtle setup:” needs network, “turtle build:” should not - presumingly. Seemed to stuck without network - but couldn’t confirm.

What is being tried -

  1. Build expo app locally after setting up the project, even without network.
  2. Host built expo apps on self-hosted servers.
  3. Have same “app-experience” while doing above compared to the apps built with “expo-managed-workflow” and built using expo build/publish steps.

How can above be achieved? What am I missing in the build process above leading to warnings?

Expo diagnostics -

Expo CLI 3.13.1 environment info:
OS: macOS 10.15.2
Shell: 3.2.57 - /bin/bash
Node: 12.16.1 - /usr/local/bin/node
Yarn: 1.21.1 - /usr/local/bin/yarn
npm: 6.13.4 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Android Studio: 3.5 AI-191.8026.42.35.6010548
Xcode: 11.3.1/11C504 - /usr/bin/xcodebuild
expo: ~36.0.0 => 36.0.2
react: ~16.9.0 => 16.9.0
react-native: => 0.61.4
expo-cli: 3.13.1

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.