Having issue with app.json after upgrading expo app in android?

I am having an error after creating new project on windows 10. I have just upgraded my expo app on my phone and now I am getting an error in terminal:

Error: Problem validating fields in app.json. See Configuration with app.json / app.config.js - Expo Documentation
• should NOT have additional property ‘nodeModulesPath’.

Cannot know what really happened. Help please!

Done. I have upgraded expo-cli and error is gone!

1 Like

I did that and I’m still getting this error. Anyone knows what to do to fix this problem ?

What does expo diagnostics give you?

My CI had an old version of expo cli and wasn’t updating … this was my root cause. Same error.

1 Like

@lanman2000 so is the problem resolved now?

Hi there,

Run this command : yarn global add expo-cli.

1 Like

For NPM, running below fixed for me:

npm install -g expo-cli

npm install -g expo-cli also solved the problem for me, for some weird reason yarn global add expo-cli did not work.

This did not work for me. Does anyone know another solution?

What OS are you on?

What does the following give you?

expo diagnostics

Also these:

npm list -g
yarn global list

hello guys!
someone this is how solved that?

Error: Problem validating fields in app.json. See Configuration with app.json / app.config.js - Expo Documentation
• should NOT have additional property ‘nodeModulesPath’.
Couldn’t publish because errors were found. (See logs above.) Please fix the errors and try again.

{ "expo": { "name": "radiomega",3940256099942544~1458002511 "description": "Ecouter radio mega live", "slug": "radiomega", "version": "1.0.0", "sdkVersion": "41.0.0", "owner": "ninjaroot509", "githubUrl": "https://github.com/ninjaroot-509/radio-mega-app", "orientation": "portrait", "icon": "./assets/icon.png", "androidStatusBar": { "barStyle": "light-content" }, "splash": { "image": "./assets/splash.png", "resizeMode": "cover", "backgroundColor": "#ffffff" }, "updates": { "fallbackToCacheTimeout": 0 }, "assetBundlePatterns": [ "**/*" ], "ios": { "supportsTablet": true, "buildNumber": "1.0.0", "config": { "googleMobileAdsAppId": "ca-app-pub-XXXX" } }, "android": { "adaptiveIcon": { "foregroundImage": "./assets/adaptive-icon.png", "backgroundColor": "#FFFFFF" }, "versionCode": 1, "config": { "googleMobileAdsAppId": "ca-app-pub-XXXX" }, "package": "com.ninjaroot509.radiomega" }, "web": { "favicon": "./assets/favicon.png" } } }

here my app.json

What is that 3940256099942544~1458002511 in the app.json that you posted? That definitely should not be there.

Also, what does expo --version give you?

I found the solution
you have to go back to sdkVersion: 40.0.0,
which means

expo update 40.0.0

sorry just an error in keyboard

That is not a good solution.

Make sure that expo --version shows something recent. e.g. mine says:

$ expo --version
4.8.1

I had a same issue but updated expo to 4.9.0 and solved it today.
npm_expo-cli@4.9.0

1 Like