Gradle build failed with unknown error. See logs for the "Run gradlew" ( phase for more information.

  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  "dependencies": {
    "@dietime/react-native-date-picker": "^1.2.0",
    "@expo-google-fonts/nunito": "^0.2.2",
    "@react-native-community/masked-view": "^0.1.11",
    "@react-navigation/native": "^6.0.10",
    "@unimodules/core": "^7.1.2",
    "@unimodules/react-native-adapter": "^6.3.9",
    "@use-expo/font": "^2.0.0",
    "axios": "^0.27.2",
    "expo": "^48.0.20",
    "expo-app-loading": "~2.0.0",
    "expo-dev-client": "~1.0.0",
    "expo-font": "~10.1.0",
    "expo-linear-gradient": "~11.3.0",
    "expo-location": "~14.2.2",
    "expo-updates": "~0.13.4",
    "geolib": "^3.3.3",
    "moment": "^2.29.3",
    "react": "17.0.2",
    "react-dom": "17.0.2",
    "react-native": "0.68.2",
    "react-native-autocomplete-input": "^5.1.0",
    "react-native-elements": "^3.4.2",
    "react-native-gesture-handler": "~2.2.1",
    "react-native-google-places-autocomplete": "^2.4.1",
    "react-native-htmlview": "^0.16.0",
    "react-native-loading-spinner-overlay": "^2.0.0",
    "react-native-maps": "0.30.2",
    "react-native-paper": "^4.12.1",
    "react-native-phone-call": "^1.0.9",
    "react-native-reanimated": "~2.8.0",
    "react-native-safe-area-context": "4.2.4",
    "react-native-screens": "~3.11.1",
    "react-native-simple-radio-button": "^2.7.4",
    "react-native-star-rating": "^1.1.0",
    "react-native-tiny-toast": "^1.0.7",
    "react-native-web": "0.17.7",
    "react-native-web-webview": "^1.0.2",
    "react-navigation": "^4.4.4",
    "react-navigation-stack": "^2.10.4"
  "devDependencies": {
    "@babel/core": "^7.12.9"
  "private": true

Hi @omotayo52

You have not asked your question very well, but I have some comments nevertheless.

AppLoading was deprecated in Expo SDK 45 and removed in Expo SDK 47:

These days you should use @react-native-masked-view/masked-view:

You have a mixture of different versions of React Navigation. Check the React Navigation upgrade documentation and get rid of react-navigation and react-navigation-stack.

Remove these.

Then run npx expo-doctor and npx expo install --check.

my production build keeps failing and this is the error message i keep getting
Gradle build failed with unknown error. See logs for the “Run gradlew” (Build Details — d0de758f-87ee-43fd-a7b7-5af6b0e06cb1 — NNRA_Safe_X-ray_Mobile — Expo) phase for more information.

OK. Did you try all of the suggestions I gave you? If so, what happened?

Also, it is normally a good idea to say how you got into the situation. e.g. “My builds were working fine with Expo SDK 44. Then I tried upgrading to Expo SDK 48 by reading the release notes for each of the Expo SDK releases and taking care of any breaking changes. Now, when I try to build I get the following error” (or something like that).

Hello Wodin,

Thank you so much, i tried the solution you gave me and its working now

Best regards

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.