Failed to compile.


I’m seeing the following error in my terminal. I’m wondering if someone can nudge me into right direction.

Failed to compile.
Module not found: Can't resolve '../../Utilities/Platform' in '/Users/rx/rn/ex-items-app/node_modules/react-native/Libraries/Components/TextInput'

Output of EXPO_WEB_DEBUG=true expo build:web

● Expo Webpack █████████████████████████ building (61%) 430/466 modules 36 active
 babel-loader › node_modules/react-native/Libraries/Components/TextInput/TextInputState.js

Failed to compile.

Cannot find module: '../Utilities/Platform'. Make sure this package is installed.

You can install this package by running: npm install ../Utilities/Platform.
Error: ./node_modules/react-native/Libraries/ReactPrivate/ReactNativePrivateInterface.js
Cannot find module: '../Utilities/Platform'. Make sure this package is installed.

Please run expo diagnostics and paste the log that’s printed out along with your question or issue!

Expo CLI 4.0.17 environment info:
      OS: macOS 10.15.7
      Shell: 5.7.1 - /bin/zsh
      Node: 14.9.0 - ~/.nvm/versions/node/v14.9.0/bin/node
      npm: 6.14.8 - ~/.nvm/versions/node/v14.9.0/bin/npm
      CocoaPods: 1.9.3 - /usr/local/bin/pod
      iOS SDK:
        Platforms: iOS 14.0, DriverKit 19.0, macOS 10.15, tvOS 14.0, watchOS 7.0
      Android SDK:
        API Levels: 28, 29, 30
        Build Tools: 28.0.3, 30.0.2
        System Images: android-30 | Google APIs Intel x86 Atom
      Android Studio: 4.1 AI-201.8743.12.41.6858069
      Xcode: 12.0.1/12A7300 - /usr/bin/xcodebuild
      expo: ~40.0.0 => 40.0.0
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: => 0.63.2
      react-native-web: ~0.13.12 => 0.13.18
      expo-cli: 4.0.17
    Expo Workflow: managed


Just floating this to the top.
I think my issue is related to this issue.
I tried several solutions mentioned in that thread but none of it worked in my case.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.