Expo Start: EAGAIN Error

Hey folks,

I am running into an issue when I run expo start and I am not sure how I can get myself ublocked. Any idea would be awesome!

PS /Users/davinci/development/sunny> expo start

Starting project at /Users/davinci/development/sunny
Expo DevTools is running at http://localhost:19002
Opening DevTools in the browser… (press shift-d to disable)
Some of your project’s dependencies are not compatible with currently installed expo package version:

  • expo-permissions - expected version range: ~7.0.0 - actual version installed: ^8.0.0
  • react-native-maps - expected version range: ~0.25.0 - actual version installed: ^0.26.1
  • react-native-webview - expected version range: 7.0.5 - actual version installed: ^8.0.6
  • react-native-safe-area-context - expected version range: ~0.3.6 - actual version installed: ^0.6.2
    Your project may not work correctly until you install the correct versions of the packages.
    To install the correct versions of these packages, please run: expo install [package-name …]

Error: spawn pgrep EAGAIN
at Process.ChildProcess._handle.onexit (internal/child_process.js:267:19)
at onErrorNT (internal/child_process.js:469:16)
at processTicksAndRejections (internal/process/task_queues.js:84:21)

Expo CLI 3.13.1 environment info:
OS: macOS 10.14.6
Shell: 3.2.57 - /bin/bash
Node: 12.16.1 - /usr/local/bin/node
Yarn: 1.19.1 - /usr/local/bin/yarn
Watchman: 4.9.0 - /usr/local/bin/watchman
Xcode: 10.2/10E125 - /usr/bin/xcodebuild
@types/react: ^16.9.17 => 16.9.22
@types/react-native: ^0.57.65 => 0.57.65
expo: ^35.0.0 => 35.0.1
react: 16.8.3 => 16.8.3
react-native: 0.59.10 => 0.59.10
react-navigation: ^4.0.10 => 4.1.1


Are you by any chance running PowerShell on your Mac?

What do you get if you type:


If you are running PS I suggest you rather use bash or zsh. To test bash, just run bash -login. Even if it doesn’t solve this issue, I would be wary of using something as uncommon as PowerShell on macOS for your shell while developing with Expo.

Then, you have some outdated dependencies and some that are too new. Try running expo upgrade.
Then for any of the libraries that Expo still complains about, run expo install dependencyname to make sure you get the right versions.


Thanks for the reply!

I was using PSCore while I was getting the trace but I get the exact same behaviour with bash as well so I do not think it has anything to do with the terminal. It works if I manually delete the .expo folder and then do expo start. But then I have to do that every time I want to restart expo.

Also I am on the latest version of expo (I run update this week) and I will try your suggestion and install the deps with expo install

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.