Expo ipa build error when opening app

I have run the exp build:ios -c before (like 2 days ago) and have completed the build and no errors and the app installed fine. Now when I build the app it does install correctly but shows a JS error on load this._nativeModule.addListener is not a function. One thing I have noticed is that the previous builds sizes where 250MB+ now it is only like 31MB+. Any help on this?

Thank you very much

31MB is really small… Did you not build simulator package?
Which SDK version are you using?
Could you provide us with your build id?

Hi,
Here is my build ID

default-ad166802-8e00-4761-8a7d-2a6442b4f795

I am using exp version 56.0.0

What do you mean “build simulator package”?

Thank you

Looking at this build - you tried to do ad-hoc build, which is not supported at the moment by expo. Probably you selected devices on developer.apple.com on appId/provisioning profile settings.
You can try just deleting your certificates and build app again.

Hi jakubste,

Thank you for the looking into this. I tried using an enterprise build

exp build:ios -c --apple-enterprise-account

but still it won’t build the entire ipa, It is still 31+ MB in size. My build is

Thank you

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.