Expo Client "Invariant Violation" on published only

I run my app in development on my iOS device / expo client over LAN, everything runs great. I publish the code (commit --> node:12 docker container on OSX CI/CD server --> publish to “development” release channel). When I open this in my expo client, some parts of the app work, others give this “Invariant Violation” error (attached image). If I manually “expo publish --release-channel development” from my dev machine, the same link now works in the expo client.

I need help with general debugging approach. How would I begin to trouble shoot this?

What I have tried:

  • running in production mode (no errors thrown / no additiional info)
  • bumping app version number to a higher number
  • completely wiping and rebuilding my docker image from scratch
  • moving packages.json dev dependencies to the dependencies section

This set up has worked in the past for almost a year, but since upgrading SDK36, iOS13, Xcode, etc. the published version always crashes. I appreciate any help in general approach / direction to debug this!

Resolved: Sharing for a potential reader in the future!

An updated third party package we used (react-native-modalize) had a breaking change where the named import changed. We 1. did not realize this breaking change and 2. the packages.json version number got out of sync (typical dev tinkering :smiley: ) causing different versions of the package to be used on the dev machine and the CI CD server. #1 caused the published version to crash, #2 is what created the inconsistent behavior between environments.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.