Exp detach Android build error

My exp sdk version is 21.0.0, when I detached my app, and want to build in Android Studio, I found this error
Screenshot at 2017-09-26 18:21:38
But, when I use exp sdk 19.0.0, no this kind of error, can someone tell me how to solve it?

You detached while on 19.0.0 then upgraded SDKed then tried to build?

Hi algebr, I upgrade sdk after detach, there is no build error, but I got this error when it is opened in simulator.
Screenshot at 2017-09-27 14:41:07

anything here help you?

https://stackoverflow.com/questions/45594935/expo-io-module-jstimersexecution-is-not-a-registered-callable-module

No, I tried, the node_modules folder is updated, but still not working. the problem is “react-native”: “https://github.com/expo/react-native/archive/sdk-20.0.0.tar.gz” in package.json I think. When I change 20 to 19 version, it works. Thanks for your help.

Basically, I just use “exp init” to initial a new tabs project, and run “exp detach”, but when I build the android project, there is a error in bundle.gradle file.
52

hey @dalu, your problem looks very similar to the one someone encountered here: https://github.com/expo/expo/issues/689

Could you try the fix they’ve described?

1 Like

Thank you! It works now.