exp build:ios Error while gathering & validating credentials (status code 404)

Hi All

I’m trying to build app to submit App Store. I used this command
exp build:ios -c
And chose the option leting Expo handle all process.

Then I got the below error.

? What's your Apple ID? xxxxx@abc.com
? Password? [hidden]
22:52:20 [exp] Validating Credentials...
22:52:25 [exp] Only 1 team associated with your account, using Team ID: 7439VY682Y
? Will you provide your own Distribution Certificate? Let Expo handle the process
? Will you provide your own Push Certificate? Let Expo handle the process
? Would you like to reuse Distribution Certificate from another app? No, please create a new one
22:54:06 [exp] Error while gathering & validating credentials
22:54:06 [exp] Error: Request failed with status code 404
22:54:06 [exp] Request failed with status code 404
22:54:06 [exp] Error: Request failed with status code 404
    at createError (/usr/local/lib/node_modules/exp/node_modules/axios/lib/core/createError.js:16:15)
    at settle (/usr/local/lib/node_modules/exp/node_modules/axios/lib/core/settle.js:18:12)
    at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/exp/node_modules/axios/lib/adapters/http.js:191:11)
    at emitNone (events.js:111:20)
    at IncomingMessage.emit (events.js:208:7)
    at endReadableNT (_stream_readable.js:1055:12)
    at _combinedTickCallback (internal/process/next_tick.js:138:11)
    at process._tickCallback (internal/process/next_tick.js:180:9)

my develop environment is here

  OS: macOS High Sierra 10.13.4
  Node: 8.9.4
  Yarn: 1.5.1
  npm: 5.10.0
  Watchman: 4.9.0
  Xcode: Xcode 9.4.1 Build version 9F2000
  Android Studio: 1.3 AI-141.2178183

Packages: (wanted => installed)
  react: ^16.3.2 => 16.4.1
  react-native: https://github.com/expo/react-native/archive/sdk-26.0.0.tar.gz => 0.54.2

Have you ever gotten this error?

I really appreciate if anyone could help!

Thank you so much!

It’s possible that this may be a transient error – have you had a chance to try again after some time?

Hi all, I started seeing this same error last evening and it persists today, I do not believe it is transient. Are there any suggested steps to get around this? It is blocking me and I’m under a strict deadline. I’m using “exp” version 55.0.4. Thank you!

I think it’s important to note that this error just appeared without any changes from my end, seemingly indicating to me that it’s an issue on the backend.

I’ve tried many times. But no change.

I tried all day in many ways. In case I provide my own certificate file, it got the error.
Cannot read PKCS#12…

I filed another help ticket describing my (very similar) issue and environment: iOS build failing: "Error while gathering & validating credentials", "Request failed with status code 404"

I’m also getting the same error. Here looks to be the endpoint with the 404 with axios:

follow-redirects options { protocol: 'https:',
  maxRedirects: 21,
  maxBodyLength: 52428800,
  hostname: 'exp.host',
  port: null,
  path: '/--/api/updateCredentials/%5B%5D',
  method: 'post',
   { Accept: 'application/json, text/plain, */*',
     'Content-Type': 'application/json;charset=utf-8',
     'Exp-ClientId': 'c-tlJph5-RT9mLAXDTJEBu0w',
     'Expo-Session': '{"id":"ec4163a6-3ff8-4fd1-82b7-60defee405f0","version":1,"expires_at":1893456000000}',
     'User-Agent': 'axios/0.16.2',
     'Content-Length': 23504 },
  agent: undefined,
  auth: undefined,
   { 'http:':
      { _connectionListener: [Function: connectionListener],
        METHODS: [Array],
        STATUS_CODES: [Object],
        Agent: [Object],
        ClientRequest: [Object],
        globalAgent: [Object],
        IncomingMessage: [Object],
        OutgoingMessage: [Object],
        Server: [Object],
        ServerResponse: [Object],
        createServer: [Function: createServer],
        get: [Function: get],
        request: [Function: request] },
      { Server: [Object],
        createServer: [Function: createServer],
        globalAgent: [Object],
        Agent: [Object],
        request: [Function: request],
        get: [Function: get] } } }

@alesca @nfen

I just deployed a fix, which should probably let you build your app again.
I’m curious about one thing. Did you change bundle_identifier in your app.json? I guess this was causing the problem on our servers.
Sorry for the trouble.

1 Like

Awesome, thanks! It looks to be working for me now

@dsokal . No, I did not change any thing.

it’s working well now. I’ve built successfully.
I really appreciated your support.
Thank You so much!

Cheer Expo Team!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.