Ejected SDK 32 app error on iOS simulator

I just updated to SDK 32 with an ejected app and am running into the following error when I run it on the iOS simulator (it builds fine in Xcode):

There was a problem loading the request app. It looks like you may be using a LAN URL. Make sure your device is on the same network as the server or try using a tunnel.


Make sure you are serving your project with Expo CLI (The experience you requested requires a newer version of the Expo Client app. Please download the latest version from the App Store)

I’ve done a decent amount of troubleshooting and reviewing previous recs on how to resolve this. Here’s my config information, and what I’ve tried so far:

Expo CLI 2.7.1 environment info:
OS: macOS High Sierra 10.13.6
Shell: 3.2.57 - /bin/bash
Node: 10.15.0 - /usr/local/bin/node
Yarn: 1.13.0 - /usr/local/bin/yarn
npm: 6.7.0 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Android Studio: 3.2 AI-181.5540.7.32.5056338
Xcode: 10.1/10B61 - /usr/bin/xcodebuild
expo: 32.0.0 => 32.0.0
react: 16.5.0 => 16.5.0
react-native: https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz => 0.57.1
react-navigation: ^3.0.9 => 3.0.9
expo-cli: 2.7.1

Tunnel (output in my terminal, it matches the tunnel displayed on the simlator): exp44488b134c41473680895ad591f9b517://

Troubleshooting steps:

  • Delete node_modules, yarn
  • Update global packages
  • Pod update/install
  • Change the target pod to different released subversions of 2.10.x and pod update/install
  • Simulator -> Hardware -> Erase all content and settings
  • Different phone versions
    • iPhone X - 12.1
    • iPhone 8 - 12.1

Has anyone else run into this? Any advice on what to try from here?

Figured it out. User error :star_struck:. The SDK version in my EXSDKVersions.plist file wasn’t updated.