EAS BUILD sentry sourcemaps failing to upload

  1. Managed workflow
  2. eas-cli version: 0.47
  3. What I have tried so far:
    A google search has mostly returned issues for bare workflow, not managed.

I have setup sentry-expo after having carefully followed the official documentation. When I run
eas build --profile my_profile --platform android
the build fails with error:

Task :app:bundleReleaseJsAndAssets_SentryUpload_440080222 FAILED
Processing react-native sourcemaps for Sentry upload.
Analyzing 2 sources
Rewriting sources
Adding source map references
stderr error: project not found

The last error says “project not found”. But I have properly created a project in sentry.io. Also I have correctly referenced it in the app.json file:

> "hooks": {
  "postPublish": [
      "file": "sentry-expo/upload-sourcemaps",
      "config": {
        "organization": "org-name",
        "project": "project-name",  // <-- !!
        "authToken": "__auth_key__",
        "setCommits": true

Hey @seyaobey, as I mentioned in your original topic, this is currently a known issue.

Closing this topic in favor of your original.