EAS build fails for Android : Execution failed for task ':expo-image-picker:compileDebugKotlin'.

managed workflow
eas-cli/3.15.1 darwin-arm64 node-v16.20.1
SDK version : 48.0.19
“expo-image-picker”: “~14.1.1”

When i try to create an android buid with eas, it gaves me this error on Run gradlew step.
It fails with this error:

FAILURE: Build completed with 2 failures.

1: Task failed with an exception.


* What went wrong:

Execution failed for task ':expo-image-picker:compileDebugKotlin'.

> A failure occurred while executing org.jetbrains.kotlin.compilerRunner.GradleCompilerRunnerWithWorkers$GradleKotlinCompilerWorkAction

   > Compilation error. See log for more details

* Try:

> Run with --stacktrace option to get the stack trace.

> Run with --info or --debug option to get more log output.

> Run with --scan to get full insights.

On other forums, it says to upgrade expo-image-picker version but in the context of SDK 44… a little bit old to try this

Tried to run npx expo install --fix to get the correct versions of my dependencies, but it logs me “Dependencies are up to date” so i don’t know what to do

Hi, could you post the output of the expo doctor command here?

:heavy_check_mark: Check package.json for common issues
:heavy_check_mark: Validate global prerequisites versions
:heavy_multiplication_x: Validate Expo Config
Unexpected error while running ‘Validate Expo Config’ check:
TypeError: Cannot read properties of undefined (reading ‘schema’) <=== don’t understand this error
:heavy_check_mark: Verify prebuild support package versions are compatible
:heavy_check_mark: Check for incompatible packages
:heavy_check_mark: Check for conflicting global packages in project
:heavy_check_mark: Check compatible dependency versions for the installed Expo SDK
One or more checks failed, indicating possible issues with the project.

Tried to build without expo-image-picker and it succeed.