EAS build failing for Android: integrity check fails for "sharp" library during install step

Managed workflow, latest eas-cli.
My project is a monorepo where two of the packages (not the mobile app) have the “sharp” library in their dependencies.

During the install step of EAS build there seems to be a download of the “sharp” library, which always works fine in iOS builds but seems to randomly fail in Android builds.
The error in the logs that seems to cause this during yarn install is:

YN0000: │ sharp@npm:0.31.2 STDOUT sharp: Integrity expected: sha512-OTmlmP2r8ozGKdB96X+K5oQE1oj(...)
➤ YN0000: │ sharp@npm:0.31.2 STDOUT sharp: Integrity received: sha512-z4PhNX7vuL3xVChQ1m2AB9Yg5A(...)
sharp@npm:0.31.2 STDERR sharp: Installation error: Integrity check failed for linux-x64
➤ YN0000: │ sharp@npm:0.31.2 STDOUT sharp: Please see https://sharp.pixelplumbing.com/install for required dependencies
➤ YN0009: │ sharp@npm:0.31.2 couldn't be built successfully (exit code 1, logs can be found here: /tmp/xfs-87acc69b/build.log)

Even though in the end it says an integrity check passes (as below) this still seems to make the step fail.

sharp@npm:0.31.2 STDOUT sharp: Integrity check passed for linux-x6

I don’t have this problem in any other build or CI environment, just EAS Build.

Any idea what could be wrong? I’m having a really hard time fixing this, even clearing the cache seems to have no effect, it just crashes sometimes and it’s really unpredictable.

I have this exact same error! Did you ever figure this out? For me it fails consistently for android and fails the integrity check. The sha it’s checking against actually signals an empty dir.

It hasn’t happened again for me in a long time - I guess it was some particular thing about EAS build that probably changed since then.
Nothing i tried fixed it back then.