eas build failed in fastlane stage

[stderr] 2022-12-12 09:53:34.870 xcodebuild[4471:13951] Requested but did not find extension point with identifier Xcode.IDEKit.ExtensionSentinelHostApplications for extension Xcode.DebuggerFoundation.AppExtensionHosts.watchOS of plug-in com.apple.dt.IDEWatchSupportCore
[stderr] 2022-12-12 09:53:34.871 xcodebuild[4471:13951] Requested but did not find extension point with identifier Xcode.IDEKit.ExtensionPointIdentifierToBundleIdentifier for extension Xcode.DebuggerFoundation.AppExtensionToBundleIdentifierMap.watchOS of plug-in com.apple.dt.IDEWatchSupportCore
[stderr] 2022-12-12 09:53:34.947 xcodebuild[4471:13951] XType: failed to connect - Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.fonts was invalidated: failed at lookup with error 3 - No such process." UserInfo={NSDebugDescription=The connection to service named com.apple.fonts was invalidated: failed at lookup with error 3 - No such process.}
[stderr] 2022-12-12 09:53:34.948 xcodebuild[4471:13951] Font server protocol version mismatch (expected:5 got:0), falling back to local fonts
[stderr] 2022-12-12 09:53:34.948 xcodebuild[4471:13951] XType: unable to make a connection to the font daemon!
[stderr] 2022-12-12 09:53:34.948 xcodebuild[4471:13951] XType: XTFontStaticRegistry is enabled as fontd is not available.
[stderr] --- xcodebuild: WARNING: Using the first of multiple matching destinations:
[stderr] { platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Any iOS Device }
[stderr] { platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Any iOS Simulator Device }
[stderr] { platform:iOS Simulator, id:F6898BCF-1F9B-4017-8C00-C42FB52DC78B, OS:15.5, name:iPad (9th generation) }
[stderr] { platform:iOS Simulator, id:8A99E458-9DF5-45FD-90B9-AE3E8D45FA33, OS:15.5, name:iPad Air (5th generation) }
[stderr] { platform:iOS Simulator, id:A9D00E67-59F6-498B-9487-E6CB0CFACD0C, OS:15.5, name:iPad Pro (9.7-inch) }
[stderr] { platform:iOS Simulator, id:DB619EE2-A7AB-4B01-8E7F-C3FD0489483E, OS:15.5, name:iPad Pro (11-inch) (3rd generation) }
[stderr] { platform:iOS Simulator, id:F86ECD5C-8048-4456-A2EE-A5092F5099F4, OS:15.5, name:iPad Pro (12.9-inch) (5th generation) }
[stderr] { platform:iOS Simulator, id:D38333AD-1820-41A9-9179-7BA12C6A00F9, OS:15.5, name:iPad mini (6th generation) }
[stderr] { platform:iOS Simulator, id:B575F055-31BB-4681-A541-93C73D3E05F7, OS:15.5, name:iPhone 8 }
[stderr] { platform:iOS Simulator, id:E65EE165-322D-430E-8955-428C34DC9E07, OS:15.5, name:iPhone 8 Plus }
[stderr] { platform:iOS Simulator, id:EAFFB577-ED7C-4B60-A91D-20CF70EBFBA0, OS:15.5, name:iPhone 11 }
[stderr] { platform:iOS Simulator, id:F6667EA1-F6F7-4304-B9D2-495992F0BC20, OS:15.5, name:iPhone 11 Pro }
[stderr] { platform:iOS Simulator, id:F0CA4CF6-38BA-4D2E-AFBC-22EE1526754A, OS:15.5, name:iPhone 11 Pro Max }
[stderr] { platform:iOS Simulator, id:4A1C0E71-0C96-40AD-A725-C6A370AF1D93, OS:15.5, name:iPhone 12 }
[stderr] { platform:iOS Simulator, id:A5DACA53-368C-4AA9-B649-B1D379696C68, OS:15.5, name:iPhone 12 Pro }
[stderr] { platform:iOS Simulator, id:1C40B471-BD95-4AD2-8E02-A4487E25EF3B, OS:15.5, name:iPhone 12 Pro Max }
[stderr] { platform:iOS Simulator, id:4814B63C-8DE9-44CC-A80D-8D60D42C655A, OS:15.5, name:iPhone 12 mini }
[stderr] { platform:iOS Simulator, id:8E2EB5DD-C321-4695-B728-F6A27FAF7D67, OS:15.5, name:iPhone 13 }
[stderr] { platform:iOS Simulator, id:4E56612B-11ED-49F2-B5EF-6E4602B0FB79, OS:15.5, name:iPhone 13 Pro }
[stderr] { platform:iOS Simulator, id:E5FAE80A-C4BD-4BFE-A831-2F7049886894, OS:15.5, name:iPhone 13 Pro Max }
[stderr] { platform:iOS Simulator, id:E4D323B3-630D-4D28-A329-6870D721E3B2, OS:15.5, name:iPhone 13 mini }
[stderr] { platform:iOS Simulator, id:DB03CB85-009E-4017-8EBE-14EC01AE8FD2, OS:15.5, name:iPhone SE (3rd generation) }
[stderr] { platform:iOS Simulator, id:A147CC3C-E896-4D76-9012-878356117872, OS:15.5, name:iPod touch (7th generation) }

when i run eas build -e staging --platform ios and eas build kicks off, but it errors out on fastlane stage. Tries twice and still the same issue.

I’ve done some research on google and the forum, can’t seem to figure out what is wrong here.

eas version:
eas-cli/3.0.0 darwin-arm64 node-v16.17.0