Doesn't operate correctly on Android devices, crashes on some

❯ npx expo --version

I’m working with managed workflow and my package.json is as follows:

  "name": "shiftscribe",
  "scripts": {
    "build:android": "npx eas-cli build --platform android",
    "build:ios": "npx eas-cli build --platform ios --local",
    "build:web": "npx expo export --platform web -c --output-dir web-build",
    "dev": "npm run start",
    "ios": "npx expo start --ios",
    "format": "npx prettier src --write",
    "lint": "eslint src/**/*.tsx src/**/*.ts",
    "lint:fix": "npm run lint -- --fix",
    "offline": "expo start --offline",
    "publish:expo": "npx eas-cli update",
    "publish:web": "firebase deploy --only hosting",
    "serve:app": "expo start --dev-client",
    "serve:web": "npx serve web-build --single",
    "start": "expo start",
    "upgrade": "expo upgrade",
    "web": "expo start --web --no-dev --host localhost --port 3000"
  "overrides": {
    "json5": ">2.2.2"
  "dependencies": {
    "@expo/vector-icons": "^13.0.0",
    "@react-native-async-storage/async-storage": "1.17.11",
    "@react-navigation/native": "^6.0.13",
    "@react-navigation/native-stack": "^6.9.1",
    "expo": "^48.0.19",
    "expo-constants": "~14.2.1",
    "expo-dev-client": "~2.2.1",
    "expo-device": "~5.2.1",
    "expo-file-system": "~15.2.2",
    "expo-font": "~11.1.1",
    "expo-linking": "~4.0.1",
    "expo-network": "~5.2.1",
    "expo-router": "^1.2.0",
    "expo-sharing": "~11.2.2",
    "expo-splash-screen": "~0.18.1",
    "expo-status-bar": "~1.4.2",
    "expo-updates": "~0.16.4",
    "firebase": "^9.22.1",
    "metro-minify-uglify": "^0.76.6",
    "react": "18.2.0",
    "react-dom": "18.2.0",
    "react-native": "0.71.8",
    "react-native-animatable": "^1.3.3",
    "react-native-dropdown-picker": "^5.4.6",
    "react-native-elements": "^3.4.3",
    "react-native-gesture-handler": "~2.9.0",
    "react-native-reanimated": "~2.14.4",
    "react-native-safe-area-context": "4.5.0",
    "react-native-screens": "~3.20.0",
    "react-native-svg": "13.4.0",
    "react-native-toast-message": "^2.1.6",
    "react-native-web": "~0.18.7",
    "styled-components": "^5.3.8"
  "devDependencies": {
    "@babel/core": "^7.19.3",
    "@babel/plugin-proposal-export-namespace-from": "^7.18.9",
    "@expo/webpack-config": "^18.0.1",
    "@tsconfig/react-native": "^3.0.2",
    "@types/react": "~18.0.27",
    "@types/react-native": "~0.70.6",
    "@types/styled-components": "^5.1.26",
    "@types/styled-components-react-native": "^5.2.1",
    "@typescript-eslint/eslint-plugin": "^5.42.0",
    "@typescript-eslint/parser": "^5.42.0",
    "babel-plugin-module-resolver": "^5.0.0",
    "eslint": "^8.35.0",
    "eslint-config-prettier": "^8.5.0",
    "eslint-plugin-react": "^7.32.2",
    "eslint-plugin-react-native": "^4.0.0",
    "prettier": "^2.8.4",
    "react-native-svg-transformer": "^1.0.0",
    "typescript": "^4.9.4"

I’m not sure where I’ve gone wrong with things and I’ve built the app using node 18.16.0, things worked well in the emulators, iOS and Android, although android had some difficulties (rather slow and choppy). But it does work.

Well I got it onto the Google Play Store and on my Galaxy S22 Ultra it crashes soon. as I open it. iOS is in review still but I’m curious what methods people do in order to fix issues such as mine, I’ve seen some other forum topics where things should be removed from package.json, and I’m hoping someone sees something.

I’ve cleaned up my images I was previously using and have react-native-svg now and still running into this issue, I had a friend download the app as well on an android device, and they can actually open it but cannot use the inputs for sign in…

I know this is a rather open topic but I’m not sure what else to do, some things I’ve tried: changed node versions back to 16.20.0, put andoidApk value in my eas.json under build and build it that way (which crashes on emulators), removed my larger images and using them through react-native-svg now.

Any help is greatly appreciated and I’ll share whatever I can more on the topic, I’m very lost in regards to why things aren’t working as they should as I’ve read the docs and mayee I’m just missing something… Thanks in advance!