Corrupt APK after build

I am going through building APK s from my project but i am having error everytime saying “error parsing the package” and for the records i can install 3rd party apps and i even created a test project using expo and built then used the APK successfully but for my specific this app with extra bit of of npm packages Is unable to create a working APK.App runs fine inside the Expo app.I can’t find anything about what might cause it -can anyone please give a hand?


I personally haven’t encountered any issues building an APK for my projects, but I would give this post a read 8 Proven Ways to Fix There Was A Problem Parsig the Package- Dr.Fone and see if any of the proposed solutions work for you (if you haven’t already tried them.)



1 Like

@adamjnav thanks mate but i tried most of them and other apps i built from expo is working fine.just this app.i have a strong feeling its because these extra npm modules still cant figure a way to correct it

For sure! I guess the best course of action would be to add the extra npm packages one by one until the error pops up to diagnose what package is causing the parsing problem. Not the most efficient solution but it should help identify the source of the issue.


@adamjnav i did that starting from the begin and i found out that the issue is coming only when a “project with tabs” is created on exp init.i think its an issue i would have to ask all of you to confirm so ill add it to expo git repo as an issue

Hi guys,
I’m having this exact same issue.

The apk file generated by exp (using the command exp build:android is unreadable.

  • I’ve uploaded the file into two different android phones and it couldn’t be installed
  • I’ve uploaded the file into Google Play Store and I get Upload error - did this with two different Google Play accounts

Here’s my gist:

Please help.
Been trying for a whole day with zero succes!

1 Like

Hey there - sorry you’ve been having so much trouble. I responded to your email but I’m replying here too in case it helps someone else. Running your app and looking at the logs I see the following error:

Failure [INSTALL_PARSE_FAILED_BAD_PACKAGE_NAME: Invalid manifest package: bad character '1']

It looks like your package name is invalid- see here for rules for package names: Configure the app module  |  Android Developers. In particular, each component must start with a letter.

Hope this helps!


Thank you so much @esamelson
Got it each component has to start with a lower case letter.
Changed it and it worked!
Now the app can be installed on an android phone and Google Play Store has accepted it.

Again, a million thanks!

my error was also the same exactly found out after this comment :smile: shit wasted days of time on this small thing. thanks @esamelson <3