CocoaPods could not find compatible versions for pod "React/RCTAnimation"

i create new expo project (FRESH PROJECT), after that i eject to Expokit and npm install.
then i follow this doc:
but got error when run pod install

first error:

[!] The name of the given podspec `Yoga` doesn't match the expected one `yoga`

solved with:

pod 'Yoga',
    :path => "../node_modules/react-native/ReactCommon/yoga/yoga.podspec",

i run again, and got second error:

[!] CocoaPods could not find compatible versions for pod "React/RCTAnimation":
  In Podfile:
    React/RCTAnimation (from `../node_modules/react-native`)

None of your spec sources contain a spec satisfying the dependency: `React/RCTAnimation (from `../node_modules/react-native`)`.

You have either:
 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.

Help me please.

i downgrade Cocoapod to 1.7.5 but same error


Cocoapods 1.8.4 & 1.7.5
expo-cli 3.9.0

Did you ever fix this? Also stuck on this part.

Has anyone ever solved this issue? I am using SDK 36 and getting the same errors

i would highly recommend not using expokit and instead upgrading to sdk37 (should be relatively simple with expo upgrade) and then ejecting to a bare project. read more about that here: