checkForUpdateAsync constantly giving new updates


I am currently on SDK 31, with an app in TestFlight. I was able to archive the app as I have had many times before. Prior to archiving, I made sure to publish the app. After the app is made available in Testflight, I downloaded and since then I have been constantly receiving update notifications whilst using Updates.checkForUpdateAsync

As a result, I am stuck in an update loop. I tried exp publish more than once but it isn’t resolving anything.

I deleted the app and created another build but to no avail. This is a concern as we have an app in production with a different expo account and do not want users to be stuck in this loop.

Any idea how we should proceed?

“updates”: {
“fallbackToCacheTimeout”: 0,
“checkAutomatically”: “ON_ERROR_RECOVERY”

Pushing anyother updates does not seem to do much.


On my third build and the problem persists.

SO I tried a 4th build. But this is not working. I have done OTA updates regularly. The difference is that I switched expo accounts to test some changes using testflight. Ever since then this problem has persisted and nothing I try seems to work anymore.

Sorry for the thread. I literally forgot to update the EXShell.plist entry for the publishUrl