Can't add firebase

Please provide the following:

  1. SDK Version: 40.0
  2. Platforms(Android/iOS/web/all): Android
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

I tried to install firebase using the expo install firebase command but it gave me an error of gyp and grpc unable to add the firebase to the react native app I’m using VSCode Latest version NodeJS LTS I tried every possible thing but nothing worked out
Here are the Screenshots of the error

you should google that error message. it is related to dependencies of the firebase package (grpc in particular)

alternatively, run yarn add firebase@8.2.3 - this is a newer version than we tested sdk 40 against but we’ve tested it for sdk 41 and it will be the recommended version when we release it. you can ignore the dependency mismatch warnings about firebase when you run expo start

If I remember correctly this is caused by grpc not having precompiled binaries compatible with the version of node you are running on Windows.
I think if you have Visual Studio (not code) installed it might compile it on the fly.
As a workaround you could see if downgrading to node 12 will work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.