Build failing for iOS after upgrading to SDK 43 - ExpoModulesCore

Local build for iOS keeps failing with eas build -p ios --local. I’m able to build the project with expo run:ios and building through xcode works too. However when I run eas build I get an error

:x: (ios/Pods/Target Support Files/Pods-Maskan/ExpoModulesProvider.swift:8:8)

6 | */
7 |
> 8 | import ExpoModulesCore | ^ compiling for iOS 11.0, but module 'ExpoModulesCore' has a minimum deployment target of iOS 12.0:

  • Bare workflow
  • eas-cli/0.34.1
  • What I have tried so far:
  1. changing deployment target for to 12.0 on both the main project and pods project on xcode
  2. updating eas-cli-local-build-plugin to the latest version
  3. ran eas build with --clear-cache flag
  4. cleaned xcode build files

I have xcode 12.5 and fastlane 2.195.0

Hey @ishaaq, are you still encountering this issue? If so, can you try creating a brand new bare project running on SDK43 and see if the same build error occurs?


you need xcode 13 to build sdk 43 projects