application not installed?

Hi. I build a file in android apk using expo.
Most of the time, however, the application not installed message appears when installing.

What action should be taken? I’m using sdk32 and rn0.59.
and here is my app.json

{
  "expo": {
    "name": "**********",
    "slug": "**********",
    "privacy": "unlisted",
    "sdkVersion": "32.0.0",
    "platforms": ["ios", "android"],
    "version": "1.0.0",
    "orientation": "portrait",
    "scheme": "**********",
    "icon": "./assets/icon.png",
    "androidStatusBar": {
      "backgroundColor": "#0052BE"
    },
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "cover",
      "backgroundColor": "#0052BE"
    },
    "updates": {
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": ["**/*"],
    "ios": {
      "supportsTablet": true,
      "isTabletOnly": false,
      "bundleIdentifier": "**********",
      "infoPlist": {
        "NSFaceIDUsageDescription": "**********"
      },
      "usesIcloudStorage": false
    },
    "android": {
      "package": "**********",
      "permissions": [
        "ACCESS_COARSE_LOCATION",
        "ACCESS_FINE_LOCATION",
        "CAMERA",
        "USE_FINGERPRINT",
        "com.majeur.launcher.permission.UPDATE_BADGE",
        "com.sec.android.provider.badge.permission.READ",
        "com.sec.android.provider.badge.permission.WRITE",
        "com.sonyericsson.home.permission.BROADCAST_BADGE"
      ]
    }
  }
}

Hi @chanho,

I’m not sure if this is precisely the cause of the error, but SDK 32 provides support for RN 0.57.

Since we use a fork of react-native where we can apply Expo-specific patches and fixes, we encourage/require use of GitHub-tagged package as react-native dependency.
The URL to which you should point your react-native dependency (in package.json) is always stated in release notes, eg. (source):

Let me know if that fixes the issue!

In addition to what @charliecruzan mentioned, I’ve seen this error message before so this post may be worth taking a glance at (specifically the SO post mentioned in it)

@charliecruzan
this is my package.json. I already use github-tagged package.
do I have something to edit? when I built apk, I put it all in expo.

"dependencies": {
    "expo": "32.0.0",
    "moment": "2.24.0",
    "react": "16.5.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz",
    "react-native-swiper": "1.5.14",
    "react-native-switch-toggle": "1.0.8",
    "react-navigation": "3.6.0",
    "sentry-expo": "1.12.0"
  },
  "devDependencies": {
    "babel-preset-expo": "5.0.0"
  },

Ah okay, you said originally you were using RN .59 so that’s why I wanted to double check. What happens when you try Adam’s solution?

same error happened with me too, i am using this dependency for react-native: “react-native”: “https://github.com/expo/react-native/archive/sdk-31.0.0.tar.gz”,
no solution yet

It does not seem to me in my case. because when I go to the settings/app after the app not installed message, pale version of my app does not appear. it just does not really work.
are others installed directly at once using expo build:android command?

Solution for me: go back into settings/apps and scroll though all apps and at the bottom was a pale version of my App1 (note the original App1 was at the top in Alphabetical order which was deleted as above). When clicking on the pale version it said “Not installed for this user”. (I had set up my nexus to have more than one user). But in the top right corner there is a three dot button. I pressed this and it said “Uninstall for all users”. Which I did and it fixed the problem. I was now able to click on App1.apk and it installed fine without the error.

1 Like

@chanho & @mohammad,

Could you share what devices this occurs on? (also let me know if you have run on other devices (different Android OS version) and it has worked)

There are actually a few fixes described in the linked SO post, depending on the OS version

i tried to install it on p20 light Hawaii and Samsung tab s device, both of them showing the same error.

I even tried to start a new project and build it, the same problem.

This is my package.json

{
“name”: “some-app”,
“main”: “node_modules/expo/AppEntry.js”,
“private”: true,
“scripts”: {
“start”: “expo start”,
“android”: “expo start --android”,
“ios”: “expo start --ios”,
“eject”: “expo eject”
},
“dependencies”: {
“axios”: “^0.18.0”,
“expo”: “^31.0.2”,
“react”: “16.5.0”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-31.0.0.tar.gz”,
“react-navigation”: “^3.1.2”,
“react-redux”: “^6.0.0”,
“redux”: “^4.0.1”,
“redux-persist”: “^5.10.0”
},
“devDependencies”: {
“babel-preset-expo”: “^5.0.0”
}
}

the problem was in the android packager name in my app.json

so it was like that:

"package": "com.<myName>.<appName>"

i replaced myName with the appName like that :

"package": "com.<appName>.<appName>"

and it worked like a magic and I was able to successfully build and install the app on multiple devices

1 Like

@mohammad
Do I have to match the name value? here is my app.json real info.

"name": "<appName>",
"scheme": "com.<myCompanyName>.<myDomain>.<appName>",
"android": {
      "package": "com.<myCompanyName>.<myDomain>.<appName>",
}
"ios": {
      "bundleIdentifier": "com.<myCompanyName>.<myDomain>.<appName>"
}

@charliecruzan
I tested it on three devices, and I’ll show you two.

  1. Samsung galaxy note4 (sm-n916l) / android 6.0.1
  2. LG V30 (lgm-v300l) / android 8.0.0

Anyone know about this??

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.