Apple crashes on startup without error message in SDK36

Please provide the following:

  1. SDK Version: 36
  2. Platforms(Android/iOS/web/all): iOS

I just updated to SDK36 and I can no longer run the app. I’ve tried to run it in the simulator. I see the splash screen for my app but then it crashes without any error logs. Was working fine on SDK35. Any ideas how to debug/fix?

Is this happening on a standalone app, or the Expo client? If it’s a standalone app, then you could try running locally in the Expo client, but in production mode (run expo start --no-dev --minify) to simulate the production environment and hopefully reproduce the crash

I guess i’m getting the same error here, but on android, SDK 36, working perfectly on developer and production mode, but crashes in standalone app on start. Splash screen appears, then the app crashes.

Android Studio Logs:

2020-01-24 14:43:31.166 32127-32127/? E/AndroidRuntime: FATAL EXCEPTION: main
    Process: com.localchat.localchat, PID: 32127
    java.lang.NullPointerException: Attempt to invoke virtual method 'org.json.JSONObject org.json.JSONObject.getJSONObject(java.lang.String)' on a null object reference
        at host.exp.exponent.t.c.a(
        at host.exp.exponent.experience.f.n(
        at host.exp.exponent.experience.f.a(
        at host.exp.exponent.experience.f$
        at android.os.Handler.handleCallback(
        at android.os.Handler.dispatchMessage(
        at android.os.Looper.loop(
        at java.lang.reflect.Method.invoke(Native Method)

It’s in development.

Seeing a similar crash in standalone mode (managed Expo app):

  at host.exp.exponent.experience.a$ (
  at android.os.Handler.handleCallback (
  at android.os.Handler.dispatchMessage (
  at android.os.Looper.loop (
  at (
  at java.lang.reflect.Method.invoke (Native Method)
  at$ (
  at (

Hi. This stack trace is from Android and unfortunately it’s impossible to tell what the problem is from that. There should be an error message just before the stack trace that gives the actual problem.

But one possibility is a known problem with dark mode on SDK 36. Another possibility is an incomplete OTA update. Another possibility is using the wrong type in your code. e.g. specifying style={{padding:"20px"}} instead of `style={{padding:20}}

Unfortunately I’m only seeing this error in one user during our live beta test so I don’t have access to the device myself.

Remove node_modules and lock file rm -rf node_modules && rm -rf package-lock.json

Reinstall packages npm install

Run expo start -c to start with clear cache

This happened to me after updating as well. I had to do this 2-3 times to get it to work. Removing the Expo app from Simulator also helps. Good luck.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.