App removed from Google Play due to policy violation with Branch

Yes we removed this from our SDK in 2017. I am not sure which version comes bundled with Expo but I would imagine it’s newer than 2.11.1.

Just be aware that an old APK could be the cause of the policy warning and Google will notify you of the build that is causing issues, so all you need to do is either remove the offending APK or update your app with a new expo build.

thanks, soon i will test this. we delete all old .apks from google play and soon will upload version with branch(builded with turtle)

Hey everyone,

We found out about the google-branch-expo issue two days ago. On our project we are currently using both Branch and Expo and it would be great if we could make it work without ejecting.

I tried the workaround using turtle-cli, explained in this post (https://blog.expo.io/changes-to-expo-branch-support-d002c4bc564e). I tried both the newest version (0.6) and the specified version (0.5.15) and the app still crashes everytime i open it.

If I don’t import react-native-branch anywhere, the app works. Otherwise it throws an error undefined is not an object (evaluating ‘t.STANDARD_EVENT_ADD_TO_CART’)

I am new to building apk’s with turtle-cli, so maybe I missed something. Are there any docs explaining the workaround in more details?

Any help would be appreciated. Thanks

1 Like

btw, while application with branch using start i see this in console:

Initializing react-native-branch v. 2.2.5
as i see about this release in github: * Updated to iOS SDK 0.22.5 and Android SDK 2.15.0.

Hey @celsiustech,

If you’re building with turtle-cli 0.5.15 you should not be using react-native-branch but rather just import it as you would normally in Expo. That version of turtle cli builds apks that still have Expo’s branch module included.

Cheers,
Adam

2 Likes

@hubex_developers, @jess, @mgaylord

Thank you for your comments! I’ve done my best to follow your lead (and instructions), but my app is still not live. For a while, I thought it had something to do with my having an old 1.0 version stuck in the beta testing branch…

But following @mgaylord’s step-by-step guide to deleting old APKs, I generated a new 1.7.0 version (identical to the 1.6.0 except for version number) and promoted the beta branch. Now my app releases look like this, but the app is still not published.

Any suggestions as to what my next step ought to be?

@geirman - in our experience, Google is rather picky about changes like this being applied to all tracks, not just the production track. I’d suggest updating all of your tracks to use the same 1.7.0 version. You can do that in the same way that you did with the Production release, by clicking “Manage” on each track and creating a new release.

Hope this helps!

1 Like

@esamelson that did the trick! I really don’t need an internal test track though. Anyway I can just delete it all together, leaving just the production track for now?

1 Like

Thanks for the quick reply.

I did replace everything and reconnected to react-native-branch. But this wasn’t the issue.

The issue was with the .turtle directory. It wasn’t updated when I installed turtle-cli@0.5.15. When I removed it and reinstalled turtle-cli the app worked :metal:

1 Like

Hi Expo Team,

Yesterday my app is rejected from playstore and received a mail and mentioned issue as below,

Issue: Violation of Personal and Sensitive Information policy

I am just using camera and storage. Using Expo sdkVersion:32.0.0. What need to be done for this issue? Please give me a solution to publish the app again in playstore.

Hi @designqube, as Adam mentioned, could you please give us some more context (specifically, the full notice) in a new/separate post? We can’t really make a helpful recommendation without specifics :slight_smile: Thanks!

Was yours ever restored? I’ve removed old builds and now on the Store Listing screen they are “Processing update”. We’ve seen that in the past but it eventually went away and we were still not in the store.

Edit: Ours did eventually finish processing and was returned to the store.

No app restored. I’m still battling.

Sorry you’re still having to deal with this fiasco @johnfredadams. It’s odd that some are not encountering the same problem. Have you tried to get more information from Google as to why subsequent attempts are not passing?

Same thing here for us, we built a new binary and uploaded to play store, now when we edit store listing, it says “Processing update” and the submit button is greyed out. I will post an update if anything changes.

Google, just removed our app from Google Play due to a policy violation : Your app is using the Branch IO SDK, which is uploading users Installed Packages information to https://api.branch.io/v1/applist without a prominent disclosure. Prior to the collection and transmission, it must prominently highlight how the user data will be used, describe the type of data being collected and have the user provide affirmative consent for such use. Make sure to also post a privacy policy in both the designated field in the Play Developer Console and from within the Play distributed app itself.

I don’t know how https://api.branch.io/v1/applist is used… Can you help us ? Thank so much !!!

Hey @olivier974,

We discuss the proposed solutions in this blog post: https://blog.expo.io/changes-to-expo-branch-support-d002c4bc564e

Also, please be sure to scroll through the thread before posting as it can often reveal some information (such as the aforementioned blog post) that will provide you with an answer or solution.

Cheers,
Adam

Thank you for your answer @adamjnav. We have build:android the application and uploaded yesterday (24hours) with new incremental number and deploy. Everything worked perfectly but the application is still deleted with the new version. No email from google… Do you think we have to keep waiting? Whats should we do else? Thanks for your help.

{
  "expo": {
    "name": "*************",
    "description": "*************",
    "slug": "***********",
    "privacy": "unlisted",
    "sdkVersion": "32.0.0",
    "version": "1.1.33",
    "orientation": "portrait",
    "primaryColor": "#cccccc",
    "notification": {
      "icon": "./assets/theme/notification.png",
      "color": "#ffffff"
    },
    "loading": {
      "icon": "./assets/theme/chargement.png",
      "backgroundColor": "#ffffff",
      "hideExponentText": true
    },
    "icon": "./assets/theme/icon-android.png",
    "updates": {
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "ios": {
      "bundleIdentifier": "**************",
      "icon": "./assets/theme/icon-ios.png",
      "infoPlist": {
        "NSLocationWhenInUseUsageDescription": "**** uses your location to help you choose ********"
      },
      "config": {
        "googleMapsApiKey": "********************"
      }
    },
    "android": {
      "versionCode": 13,
      "package": "*********",
      "permissions": [],
      "config": {
        "googleMaps": {
          "apiKey": "********************"
        }
      }
    }
  }
}

npm update was done before the android:build

{
  "name": "*******",
  "main": "node_modules/expo/AppEntry.js",
  "private": true,
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "eject": "expo eject",
    "test": "node ./node_modules/jest/bin/jest.js --watchAll"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "axios": "^0.18.0",
    "expo": "^32.0.6",
    "react": "16.5.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz",
    "react-native-checkbox": "^2.0.0",
    "react-native-keyboard-aware-scroll-view": "^0.8",
    "react-native-picker-select": "^5.2.5",
    "react-navigation": "^3.9.0"
  },
  "devDependencies": {
    "jest-expo": "^32.0.0"
  }
}

What if you import DangerZone but aren’t using the Branch part of it - will that still include the Branch SDK?

I am using DangerZone.Localization and I’m thinking that is causing expo to still include Branch in my build even though I’m not using Branch

Hi all,

We got same issue but just resolved and app re-published.

Let us share the successful experience below:
Must do:

  • By Expo team, expo build:android ( --no-publish flag is optional)
  • Update all Internal testing apk to new build. 99% sure that anywhere (e.g. internal testing) pointing to old apk will fail the re-submission.
  • Delete apk: https://branch.app.link/apk-removal-guide

***Not sure step below necessary ***

After resubmited, we got published again after about 15mins.
(1 key thing: We re-submitted the app without removing the old apk in internal test. We don’t get response for 2 days so we believe it takes less than 30 mins for approval if you’ve done the right things)

Good luck everyone.

Rgds,
Gil