App crash in production but not in development

I have created a app using expo and everything works fine in development. I found no error. I tried it with expo start --minify --no-dev. Still everything works fine and no error
So I used eas build and build a .abb file. I uploaded it to play console. Now when it come on play store, I tried it but it crash every time. App is not opening in any phones. It show the splash screen and then it crash.

I m using latest version of expo and eas cli.
My app on playstore

"dependencies": {
    "@expo/vector-icons": "^12.0.0",
    "@react-native-community/datetimepicker": "4.0.0",
    "@react-native-community/netinfo": "7.1.3",
    "@react-navigation/drawer": "^6.4.1",
    "@react-navigation/material-top-tabs": "^6.2.1",
    "@react-navigation/native": "^6.0.10",
    "@react-navigation/native-stack": "^6.6.2",
    "@sentry/react-native": "^3.4.3",
    "expo": "~44.0.0",
    "expo-ads-admob": "~12.0.0",
    "expo-application": "~4.0.1",
    "expo-constants": "~13.0.1",
    "expo-device": "~4.1.0",
    "expo-file-system": "~13.1.4",
    "expo-image-picker": "~12.0.1",
    "expo-notifications": "~0.14.0",
    "expo-permissions": "~13.1.0",
    "expo-secure-store": "~11.1.0",
    "expo-speech": "~10.1.0",
    "expo-status-bar": "~1.2.0",
    "expo-updates": "~0.11.7",
    "react": "17.0.1",
    "react-dom": "17.0.1",
    "react-native": "0.64.3",
    "react-native-gesture-handler": "~2.1.0",
    "react-native-pager-view": "5.4.9",
    "react-native-reanimated": "~2.3.1",
    "react-native-tab-view": "^3.1.1",
    "react-native-web": "0.17.1",
    "react-native-webview": "11.15.0",
    "sentry-expo": "^4.0.0",
    "simpler-state": "^1.1.0"
  "devDependencies": {
    "@babel/core": "^7.12.9"
  "private": true

please refer to this guide for troubleshooting help: Troubleshooting build errors and crashes - Expo Documentation

i am facing the same issue. i have run the standalone apk on expo go it shows the error Manifest string is not a valid json object or string

Hi @stevepath

This is not how it’s supposed to work. Maybe the following post will clarify the situation: