6 days ago EAS built my project. Today, same code without changes is not being compiled.

I am using the last eas-cli version.

6 days ago, I compiled my project which uses Expo SDK 47 and expo-image 1.2.1

I read expo-image was supported on Expo SDK 46 too.

The reason why I am not currently upgrading expo to SDK 48 is because I am using the non-modular Firebase JS SDK, which imports AsyncStorage from react-native package (deprecated in new architecture).

Well, everything worked fine 6 days ago, EAS compiled my project with expo-image and Expo SDK 47. The app doesn’t crash, so it seems expo-images works fine on SDK 47.

Today, I have tried to rebuild the same code. 0 changes. No dependencies updates.

EAS is failing on pods installation with the message “no package name found”.

What happened?

I had exactly same issue today when building for iOS, I got the following error message in the “Install Pods” step.
PS: Expo SDK 47 + expo-image@1.2.3, it was building fine a few days ago.

Using Expo modules
[Expo] Enabling modular headers for pod ExpoModulesCore
[Expo] Enabling modular headers for pod SDWebImage
[Expo] Enabling modular headers for pod SDWebImageWebPCoder
[Expo] Enabling modular headers for pod SDWebImageAVIFCoder
[Expo] Enabling modular headers for pod SDWebImageSVGCoder
Auto-generating `.xcode.env.local` with $NODE_BINARY=/Users/expo/.nvm/versions/node/v16.18.1/bin/node
error Failed to build the app: No package name found. Found errors in /Users/expo/workingdir/build/node_modules/expo-image/android/src/main/AndroidManifest.xml.
[!] Invalid `Podfile` file: unexpected token at 'info Run CLI with --verbose flag for more details.

 #  from /Users/expo/workingdir/build/ios/Podfile:14
 #  -------------------------------------------
 #    use_expo_modules!
 >    config = use_native_modules!
 #  -------------------------------------------

Error: Unknown error. See logs for more information.

it looks like the error that you are seeing is coming from @react-native-community/cli autolinking - it’s possible that they deployed a new version that causes this problem, but given that you believe you didn’t change any dependencies (maybe lockfile wasn’t committed?) that seems unlikely. that said, ymmv when using more recent libraries on older sdk versions. i suspect you will be able to reproduce this problem locally in your project as well (npx expo prebuild -p ios).

feel free to share a minimal reproducible example or more info to allow folks to help you

@brents @mark.zhou Upgrading was my only option. I thought it would take me a week because I was using the namespaced version of Firebase. By the way, in Firebase 10.0.0, we can access the compat folder, which offers the same namespaced API (<v9.0.0) too. The only problem I have experienced with Firebase 10.0.0 is Analytics. Since expo-firebase-analytics has been deprecated in SDK 48, I decided to migrate to react-native-firebase, which is also namespaced and seems to offer a better performance than the official Firebase JS SDK (and the advantage of offline DB persistence).

This solves my issue but, if you don’t want to upgrade right now, check this: [EAS Build] - Expo SDK 47 + expo-image "No package name found" · Issue #23409 · expo/expo · GitHub

1 Like

@victoriomolina I have exactly the same issue. I tried the same code (which worked before), nothing changed, doesn’t compile today with the same error.

How exactly did you resolve yours? Updated to SDK 49?

1 Like