Unnecessary Permissions on Android

My app is ready to submit to Google Play but when I upload it, I see that it’s requesting permissions such as android.permission.ACCESS_BACKGROUND_LOCATION, android.permission.ACCESS_COARSE_LOCATION, android.permission.ACCESS_FINE_LOCATION. I don’t need any of these. I tried to get rid of them by adding the following in my app.json:

   "android": {
      "versionCode": 2,
      "package": "com.mereagency.merechurchdemo",
      "adaptiveIcon": {
        "foregroundImage": "./assets/ANDROID_foreground.png",
        "backgroundImage": "./assets/ANDROID_bg.png"
      "permissions": []

But the extra, unnecessary permissions remain. I’d ignore it except that Google is asking me to justify why location services are needed. Can someone point me toward what I’m doing wrong?

Expo CLI 4.2.1 environment info:
OS: macOS 10.15.7
Shell: 5.7.1 - /bin/zsh
Node: 12.18.1 - /usr/local/bin/node
npm: 6.14.5 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
CocoaPods: 1.10.0 - /usr/local/bin/pod
Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
Android Studio: 4.1 AI-201.8743.12.41.7042882
Xcode: 12.4/12D4e - /usr/bin/xcodebuild
expo: ~40.0.0 => 40.0.0
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
expo-cli: 4.2.1
Expo Workflow: managed

Is this a new app or has it been published before? Or as a test version?

See this post (and the rest of the thread) for some more info on this:

Thanks for the response. I’ve tried the solutions that others have tried, to no avail. Some more info:

  • I’m on SDK 40
  • I’m using managed workflow
  • this is a brand new app I’m trying to submit to Google Play as an internal test release
  • per above, I have an empty android.permissions array in app.json

Any other thoughts would be very welcome.

please see this thread: Android app rejected because of background location · Issue #11918 · expo/expo · GitHub

Thanks a ton for posting that! For anyone else having this problem, the issue was that I was using eas build rather than expo build.After building with expo build:android --type apk --release-channel permission-audit, I was able to upload the build to Google Play with no issue.

1 Like

ah yes - eas build is not ready for managed workflow production apps yet - that’s coming soon :slight_smile:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.