Metro bundler running on different Port than one mentioned in connection

As the title says when I start my project it says metro bundler starting on port 19001(or some other port). But at the bottom left in Lan connection the link says 19000 at the end. Because of it when I run the project using Expo app , some different project runs.

I made sure that there’s no other project currently working or anything else. Here’s the screenshot.

any new on this one? i have the same

I had an issue with the Expo app showing the wrong project a few days ago. For me the only thing that fixed it was clearing the cache/data of the app on my phone. It seems that the app had somehow cached the JS and was not loading it again from the development server.

I think the ports are a red herring. The bundler is started on port 19001, but the port that the app needs to connect to (in the above case) is 19000.

1 Like

Thank you. This helps a lot :slight_smile:

Thanks wodin

What’s the reason why I don’t have this browser interface?